Sonarr v3 (latest) will not import shows and cannot see manual added shows

Sonarr version 3.0.6.1265: 3.0.6.1265
Mono version (if Sonarr is not running on Windows):
OS: Windows
Debug logs:
Description of issue:

  1. I had this problem before when I beta tested v3 and it’s back.
    I upgraded over my v2 version which worked flawlessly, even after restoring after the last v3 attempt.

When a new show downloads, it sits in my downloads folder! It does not move to the proper location for plex to see it. I have no clue why it is doing this.

  1. Also I have tried to manually add a new show in which I already had 4 previously downloaded episodes and sonarr v3 cannot see the 4 files sitting there.

I have my files in x:\TV Shows\Tv Show Name\Season 01

what setting do i need to fix to get v3 to work like v2?

thanks!

Without these, I’m guessing permissions.

apologies! I will get these…

you are correct! I just turned on debug and i see perm issues… hmmm… sonarr is installed on C: but the downloaded files and media are on separate drives… where is the perm issue coming from?

2021-07-05 16:05:14.7|Debug|ImportDecisionMaker|File accepted
2021-07-05 16:05:14.7|Warn|ImportApprovedEpisodes|Couldn’t import episode P:\NZBGet\complete\Series\City.on.a.Hill.S02E04.720p.HEVC.x265-MeGusta [d8a60f763]\abc.xyz.2938f782d99146.mkv

[v3.0.6.1265] System.UnauthorizedAccessException: Access to the path ‘P:\TV Shows\City on a Hill’ is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
at System.IO.Directory.CreateDirectory(String path)
at NzbDrone.Common.Disk.DiskProviderBase.CreateFolder(String path) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Disk\DiskProviderBase.cs:line 190
at NzbDrone.Core.MediaFiles.EpisodeFileMovingService.CreateFolder(String directoryName) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\MediaFiles\EpisodeFileMovingService.cs:line 203
at NzbDrone.Core.MediaFiles.EpisodeFileMovingService.EnsureEpisodeFolder(EpisodeFile episodeFile, Series series, Int32 seasonNumber, String filePath) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\MediaFiles\EpisodeFileMovingService.cs:line 166
at NzbDrone.Core.MediaFiles.EpisodeFileMovingService.MoveEpisodeFile(EpisodeFile episodeFile, LocalEpisode localEpisode) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\MediaFiles\EpisodeFileMovingService.cs:line 75
at NzbDrone.Core.MediaFiles.UpgradeMediaFileService.UpgradeEpisodeFile(EpisodeFile episodeFile, LocalEpisode localEpisode, Boolean copyOnly) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\MediaFiles\UpgradeMediaFileService.cs:line 77
at NzbDrone.Core.MediaFiles.EpisodeImport.ImportApprovedEpisodes.Import(List`1 decisions, Boolean newDownload, DownloadClientItem downloadClientItem, ImportMode importMode) in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\MediaFiles\EpisodeImport\ImportApprovedEpisodes.cs:line 109

2021-07-05 16:05:14.7|Debug|CompletedDownloadService|Not all episodes have been imported for City.on.a.Hill.S02E04.720p.HEVC.x265-MeGusta [d8a60f763]
2021-07-05 16:05:14.7|Debug|Api|[GET] /api/v3/command: 200.OK (1 ms)

So sonarr is running as “LOCAL SERVICE”… hmmm…

I changed the service to run as LOCAL SYSTEM temporarily instead and now it is working properly (I have a feeling sonarr v2 was like this).

Once I figured out the issue it was easier to search for answers… because I upgraded from v2 I did not have the option to choose how it starts… I found a forum here that clarifies this, so hopefully this thread helps the next person: