Sonarr / Synology Fails after package update

Sonarr version v2.0.0.5301: (20190320-15)
Mono version 5.18.0.240: (5.18.0.240-12)
OS Synology DSM 6.2.1-23824-6:
Debug logs:[https://drive.google.com/drive/folders/18DT5n2WR35J0DdKARDocF57iHtlemUGw?usp=sharing](http://google drive share with log files)

Sonarr failed to run the package service after upgrade of Sonarr & Mono on Synology:

Not sure what the issue is?
But by looking at the logs I suspect it is a compatibility issue been sonnar code base and mono.
Can anybody give me some guidance on how to get Sonarr working again.
(I now know not be one of the first to upgrade and look for issues in forums before doing such)

I’m having the same issue with the same versions.

I have tried uninstalling and reinstalling both mono and sonarr but i get the same result and the same error in the install log.

chown: cannot access '/volume1/@appstore/nzbdrone/var/.config': No such file or directory

It does seem that the directory mentioned doesn’t exist in that location, perhaps Sonarr isn’t installing correctly. I did backup all the Sonarr files before uninstalling and it hasn’t recreated any of the folders that were there before.

I know it doesn’t help much but might shed some light on what is occuring.

I’ve been messing around for a while and have got Sonarr and Mono back up and running.

I’ve uninstalled the newest versions of both and downloaded the previous versions of each package from https://synocommunity.com/packages.

I found the architecture version i needed to download on the list here https://github.com/SynoCommunity/spksrc/wiki/Synology-and-SynoCommunity-Package-Architectures

Click ‘Manual Install’ in the Package Center and install Mono first then Sonarr using the files you’ve downloaded and it should be up and running again.

I’d also check that they’re not set to auto-update but I don’t think these packages support that.

I’m currently trying to restore my backup database but that’s a story for another time! :stuck_out_tongue_closed_eyes:

EDIT: I thought it worth pointing out that uninstalling Sonarr will wipe out your entire config for it so I’d back up the nzbdrone directory first. If you still have Sonarr in place you might be able to just downgrade Mono and get it working again. I’d already uninstalled both before trying the fix above so wasn’t able to try this.

I hope this helps!

2 Likes

Thanks a lot! Reinstalling both previous versions of Mono and Sonarr did the trick for me.

about your edit: I tried downgrading just Mono first but that wasn’t allowed and it couldn’t be uninstalled while Sonarr was still installed so reinstalling both seems to be the only option

EDIT: and I took note of your suggestion to back up the config folder first… saved me a lot of resync work :grinning:

look at running docker and the sonarr container, its much cleaner in the long run and upgrading becomes super simple

Thanks for your help. I was having the same problem too and seems to be fixed once I rolled back both Mono and Sonarr. Just curious but has anyone tried to update Sonarr after rolling back both but keeping Mono’s version as the old one?

I’ve updated Sonar but only from within it’s GUI not from the package center. I wasn’t brave enough to try that after the hassle I’d had with it!

Any update on this issue? Has anyone tried to update Mono and Sonarr through Synology?

Anyone found an easier way to fix this. I just restarted my server after a power outage and sonarr is down. I have no desire to learn how to backup the system so that I can uninstall sonarr and down grade. Can someone point me to a guide for the sonarr docker solution and how to restore from a backup?

After looking into this more the logs showed that another instance of it was running. I restarted my DS918+ and its working.

Anyone solved this. Sonarr wants to update mono to latest version when installing , which seems to break sonarr as soon as I start adding series to my config

It seems that I end up with that exact issue but only recently. It seems to me that the issue is not mono but only in the script as trying to run sonarr from DSM UI will start nzbdrone but will fail to track the service status.

If you ssh into your synology and run ps -eaf | grep nzbdrone, you’ll see the process running, a bit later, sonnarr UI is available.

Issue with that is that you must manually start sonarr each time you boot your synology.

root@MANGOOSE:/var/packages/nzbdrone/scripts# ps -eaf | grep nzbdrone
root 32364 10341 0 22:26 pts/6 00:00:00 grep --color=auto nzbdrone
root@MANGOOSE:/var/packages/nzbdrone/scripts# /bin/sh /var/packages/nzbdrone/scripts/start-stop-status start
/var/packages/nzbdrone/scripts/service-setup: line 204: syntax error: unexpected end of file
Starting …
/var/packages/nzbdrone/scripts/start-stop-status: line 16: ${LOG_FILE}: ambiguous redirect
/var/packages/nzbdrone/scripts/start-stop-status: line 20: ${LOG_FILE}: ambiguous redirect
/var/packages/nzbdrone/scripts/start-stop-status: line 22: call_func: command not found
/var/packages/nzbdrone/scripts/start-stop-status: line 29: [: : integer expression expected
/var/packages/nzbdrone/scripts/start-stop-status: line 51: ${OUT}: ambiguous redirect