Sonarr & Radarr not sorting files using Docker on Synology


#1

Sonarr version (exact version):
2.0.0.5252
Mono version (if Sonarr is not running on Windows): 5.18.0.225
OS: DSM Docker
Debug logs:
Description of issue: When I select files on Sonarr/Radarr it sends them to SABnzbd it downloads and shows on both Sonarr and SABnzbd, once it finishes downloading, it goes to completed on SAB and shows as 100% on Sonarr but not completed, files move from incomplete to complete folder but doesn’t then move to my media folder with naming convention used.

I am completely new to using a NAS SABznbd Sonarr Radarr etc, I have a Synology DS1815+, I have spent several hours in the past 2 weeks trying to get this up and running.

I have run the software successfully internally on my laptop but couldn’t map it to my nas to download directly to it, i then installed it via syno community apps, which worked but would crash and become inaccessible after a day and finally went with dockers, where I am having the above issue.

Is there a temporary solution I can get Sonarr to move the files to the media folder with names changed etc?

I also have a spare i5 laptop about 3-4 years old that is not being used and can be used as a dedicated PC connected to my NAS etc if this would help solve the problem.

Please let me know any other information I need to provide to solve the problem. Thanks, Krish


#2

if youre using docker on the same host then you need to ensure that the sab (any indexer) and sonarr containers have an identical volume setup that points to the the same download location, otherwise it wont be able to see the path sab is telling it

what volume mappings do you have for both containers, and what location is sab set to save to?

have you setup a category in sab for the sonarr downloads, and put that in sonarrs indexer settings for sab?

the debug logs would be helpful too, that way we can tell whats actually going on


#3

Thanks for the reply, i had ensured the volumes were mapped correctly, I tried reinstall a couple times, then decided to try NZBGet, which worked 1st time.

I now finally have Sonarr and Radarr running :sunglasses:

I havent managed to get VPN working well, i joined up to IP Vanish… I havent got remote access working to access sonarr/radarr remotely.

I noticed some series have downloaded as zip files etc, which other utility software should i consider putting on my NAS to run smoother.

Any other things i should look into getting software or hardware to improve my setup?

If there is any guides anyone recommends please point me to them.

Thanks, Krish


closed #4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.