Sonarr having issues with http requests: Parameter name: src ---> System.ArgumentNullException: Value cannot be null

Sonarr version (exact version): 2.0.0.5322
Mono version (if Sonarr is not running on Windows): 5.14.0.177
OS: Linux (inside docker container linuxserver/sonarr:latest)
Debug logs: https://pastebin.com/VzWyLfA6
Description of issue:

I run several docker containers to manage my media. Specifically, I have a haugene/transmission-openvpn as my download/vpn client and linuxserver/sonarr. The configuration has been working fine until a couple days ago. Sonarr’s logs are now filled with issues that all have a similar error:

Parameter name: src —> System.ArgumentNullException: Value cannot be null.

Initially sonarr was complaining that it lost contact with the downloader. When I tested that, it fails authentication (and I’m absolutely sure it’s accurate as I can connect to it with the same credentials from a browser). My radarr container is also failing but it shows the above string. It seems if I can get to the bottom of why this error is happening, all will be right again (fingers crossed).

My logs are filled with various items (Transmission, ProxyCheck, TaskExtensions, …) whose backtraces all have the above string in them.

Obviously something has gone off the rails. Searching on the web there are mentions of people having problems with mono in the past. However, this docker image has its own mono in it and AFAIK, it hasn’t changed recently. The fact that both sonarr and radarr are experiencing the same issue and it started at the same time makes me wonder if I’ve picked up a bad docker upgrade on the hosting server or something. I’m not sure if that has changed recently or not.

I’ve tried wiping all docker images and pulling them again (I use docker-compose). No love.

The docker host is Ubuntu 19.04 based, is fully patched. Docker version 19.03.1, build 74b1e89

Any ideas on how to get these containers happy again would be greatly appreciated. As far as I can remember, no configuration changes have been made of late. It was working fine a few days ago and then it went sideways.

If there’s additional information required to help isolate this issue do let me know.

Thank you for any offered aid.