Sonarr download issue

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows): mono version 5.10.0.160
OS: macos Catalina
Debug logs:
Description of issue: I have sonarr and nzbget running but i noticing that one show that exists in sonarr has some episodes that are not downloading. When i check the blacklist in sonarr i see the episodes listed and when i check the history in nzbget i see that the episodes are being deleted showing under the hidden. When i check the history in nzbget while trying to download one of those episodes I that the status starts off as a copy then changes to deleted.

I’ve tried clearing the blacklist in sonarr and re-downloading but that doesn’t seem to be helping. What else can i do to resolve this?

Have you tried clearing the duplicate history in NZBget? Sounds like it’s removing them because it sees them as duplicates, but if they fail again you’ll either need to find other posts or add a secondary usenet provider as a fallback.

Yes I have tried clearing the history and the messages from nzbget. I currently have 3 different usenet providers listed in nzbget that are not on the same backbone.