Sonarr docker v2 not updating to v3

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows): 4.2.3
OS: Docker (Synology)
Debug logs: https://pastebin.com/emndMUg6
Description of issue:
I noticed that Sonarr is officially v3 now and I’m still at v2 so I tried updating my docker container on Synology as I always do with all my containers. I even checked the update instructions and I followed them to the letter, but my Sonarr remains v2.

  • Stopped container (v2)
  • Downloaded /linuxserver/sonarr/latest
  • Cleared container (v2)
  • Started container… remains v2

I even tried creating a brand new container that just points to the data director of the v2 installation

  • Stopped container (v2)
  • Downloaded /linuxserver/sonarr/latest
  • Created new container with exact same settings
  • Started container… remains v2

I don’t see any references in the logs that it’s trying to update my installation to v3, except for the 2 lines of MigrationLogger, but I don’t know if they are related. Unfortunately the logs don’t show anything else that resembles an upgrade (both docker logs and sonarr logs).

Any idea on how I’m going to get my Sonarr on v3?

Edit: ugh nevermind I’m dumb. I restored my container once after a failed attempt to upgrade to Sonarr v3 in preview stage, and now the old container didn’t point to the actual new image. When deploying the new container I was also using the restored backup without noticing.

My bad, I recreated a new container using the right image and it works now.