Sonarr CheckForFinishedDownload Task Hangs, Persists Through Sonarr Restarts

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows): 6.8.0.105
OS: Ubuntu Server 20.04.1 LTS
Debug logs: https://www.dropbox.com/s/hr5b6xdpxv4sdwk/sonarr.trace.txt?dl=0
Description of issue: I’ve been having this recurring issue where, seemingly randomly, the CheckForFinishedDownload task doesn’t ever run despite being scheduled to run. Attempting to manually run it results in the task icon spinning indefinitely. It looks like the task doesn’t run because it’s already pending. This seems to persist through restarts, however, and results in an empty activity feed after restarting. I managed to get it unstuck at some point, I think a system reboot fixed it (restarting the service through systemd however doesn’t work), but I haven’t had any luck since. I’ve just recently setup Sonarr and have been importing my existing library and using it to grab missing files.

I looked a bit more closely at the logs and realized the hardlinking was throwing an exception. I didn’t really think about it initially, but this makes sense since I have my seedbox mounted through sshfs, and after reading a bit it seems like I can’t use hardlinks in this case. I’ve changed the setting and performed a system restart, but the issue seems to persist. I’ll post another log file once I get stuck and can’t find any further issues to look into.

EDIT: Here’s another log after I disabled hardlinks - https://www.dropbox.com/s/hdixt95g4luymey/sonarr.trace.2.txt?dl=0
The issue still persists, though Sonarr did eventually start working (once the task expired maybe? idk) and worked for a while but eventually died again. The task remains stuck after restarting Sonarr, the provided log shows everything from start to failure, but I didn’t notice anything peculiar (beyond the task failing).

It looks like it’s importing files:

21-1-7 04:46:57.6|Debug|DiskTransferService|Copy [/mnt/seedbox/Ghost.in.the.Shell.Stand.Alone.Complex.S02.1080p.BluRay.AAC5.1.x264-Tenderness[rartv]/[OZC]Ghost in the Shell S.A.C. 2nd GIG E05 'Inductance'.mkv] > [/mnt/storage/Plex/Anime_TV/Ghost in the Shell Stand Alone Complex/Season 1/Ghost in the Shell- Stand Alone Complex - S01E05 - Decoy Bluray-1080p.mkv]

And again a few seconds from the end of the log:

21-1-7 04:55:40.9|Debug|DiskTransferService|Copy [/mnt/seedbox/Psycho-Pass.S02/Psycho-Pass.S02E01.mkv] > [/mnt/storage/Plex/Anime_TV/Psycho Pass/Season 2/Psycho-Pass - S02E01 - The Scales of Justice HDTV-1080p.mkv]

Oh okay, I think I understand. So importing blocks the check for finished update task? I’m guessing it gets stuck for a while because it’s importing whole seasons and locks access until the season finishes?

In v2, correct. In v3 checking and importing are separate so it’s not an issue.