SOLVED: Update broke macOS install...help please

Sonarr version (exact version): Not sure, I was recent on mac up until this last update.
Mono version (if Sonarr is not running on Windows): 6.12.0.122
OS: Mac Catalina 10.15.7
Debug logs: https://privatebin.net/?7212c456daced7a7#G3AERT5z39q5dptEKQZNRFZ9CoBYZKBAu4yHX55TbJ2Z
Update logs: https://privatebin.net/?6d0858ea3f1612fb#Bkq3QqFWKTqd6yEshcSKKU5C1hZoxYrvuYsUwddMVoL9
Description of issue: tried running the latest update from the interface, I can not start Sonnar now

have you tried downloading the latest version and drag-drop to applications and say replace or keep-both see which one works and then you can restore the database

i have done this in the past.

Hello Great,

Thanks for the reply. I just downloaded the latest and did the drag-drop keeping both instances. My original still appears dead in the water. The new install opens, but shows DataMapper error returning the following when I go to localhost:8989

The DataMapper was unable to load the following field: ‘Languages’ value: ‘[ { “language”: 30, “allowed”: false }, { “language”: 29, “allowed”: false }, { “language”: 0, “allowed”: false }, { “language”: 13, “allowed”: false }, { “language”: 17, “allowed”: false }, { “language”: 14, “allowed”: false }, { “language”: 3, “allowed”: false }, { “language”: 11, “allowed”: false }, { “language”: 18, “allowed”: false }, { “language”: 12, “allowed”: false }, { “language”: 15, “allowed”: false }, { “language”: 24, “allowed”: false }, { “language”: 21, “allowed”: false }, { “language”: 8, “allowed”: false }, { “language”: 5, “allowed”: false }, { “language”: 9, “allowed”: false }, { “language”: 22, “allowed”: false }, { “language”: 27, “allowed”: false }, { “language”: 23, “allowed”: false }, { “language”: 20, “allowed”: false }, { “language”: 4, “allowed”: false }, { “language”: 2, “allowed”: false }, { “language”: 19, “allowed”: false }, { “language”: 16, “allowed”: false }, { “language”: 1, “allowed”: true }, { “language”: 7, “allowed”: false }, { “language”: 6, “allowed”: false }, { “language”: 25, “allowed”: false }, { “language”: 10, “allowed”: false }, { “language”: 28, “allowed”: false }, { “language”: 26, “allowed”: false } ]’. ID does not match a known language Parameter name: id Version 3.0.8.1507

I’m assuming this has to do with your suggestion of " then you can restore the database"

How does one restore the database?

Cheers…

Those errors are caused from moving to main from develop which is not supported and explained multiple times in the docs. Databases are not backwards compatible.

Move your database aside, change your branch back to develop, let sonarr update, and then restore your database. Backup/restore is also covered on the FAQ

Your update failed because your system or something deleted critical files in the tmp dir.

2022-07-18 00:20:13.0|Fatal|UpdateApp|An error has occurred while applying update package.

[v3.0.8.1540] System.IO.DirectoryNotFoundException: Could not find a part of the path '/var/folders/pf/byp8j98j03q_cvks7hbjjlm00000gn/T/sonarr_update/Sonarr'.

Based on their logs they were running develop, which is not compatible with the Main branch. They’d need to reinstall, move their database aside, let sonarr update, and then restore their DB

Those types of errors posted later are also clearly covered on the FAQ

https://wiki.servarr.com/sonarr/faq#can-i-switch-between-branches

Thanks to BakerBoy for the replies…
Is anyone able/willing to help me figure out how to “move (my) database aside”?

Cheers and thanks in advance for any replies.

read the FAQ posted above, they may seamed for docker or linux but MAC is basically tha same.
you need to cp sonarr.db to your desktop or another folder and do the steps mentioned on the link.
Google some terminal commands for mac if you are not familiar with directories and copy/paste on a terminal