[solved] Series' root folder is (/tv) empty; was working, now doesn't process completed downloads


#1

Sonarr version (exact version): 2.0.0.5322
Mono version (if Sonarr is not running on Windows): 5.10.1.47
OS: Debian (Open Media Vault) Docker.
Debug logs: https://pastebin.com/03SmsYc5

Hello there,
I’m having a really odd problem.
I have a server (open media Vault) sitting in my subnet running Sabnzb, utorrent and file services.
On the same server is a docker container running Sonarr.

Everything has been running perfectly for around two years. However now, sonarr is not moving the files downloaded or recognizing that the download has finished.

so sonarr searches my indexers, it sends an nzb to sabnzb to download. Sabnzb then downloads and unpacks it into the finished folder. At that point Sonarr is supposed to go and get it, rename the file, delete the fluff and move it to the correct tv\subfolder.

instead sbnzb leaves the download in ‘activity’ and the log states
19-5-20 18:54:27.7|Warn|DiskScanService|Series’ root folder (/tv) is empty.

which it isn’t.
To the best of my knowledge i haven’t changed anything. I have tried updating sonarr to the latest version and restarting the server. no change.
My mediacentre (KODI on Openelec) can see the tv folder fine and updates it’s library every few hours like it’s supposed to.

any ideas what i should do?

I first noticed it a few days ago when i tried to add the series Happy!, is it possible the ‘!’ has upset the scripts or something?


#2

I am having the same issue, all of a sudden my root directory is “missing” it showss the UNC path through Sonarr but I can’t search any UNC paths now.


#3

Got it figured out on the Discord, for my issue I used a different user for the services and that user lost access to the network share for some reason. Logged into the user and re-logged in and saved to the network share and its all good now.


#4

Thanks Otep, that does sound very similar. I did check the user accounts and it seemd fine but i’ll make a new user called dockeruser2 and apply that over the top and see what happens.


#6

ugh, i’m way out of my comfort zone.
as far as i can tell, my docker container is running a user called “dockerperson” and that person it a member of the root group.
And root has rwx to /tv so i’m not sure what the problem is.
I’ll try the discord channel.

ok, so i’m using openmediavault which has a plugin for docker, which was being odd.
i’d make changes, come back to the gui and the changes had gone.
one of the changes was a wierd mapping to /tv
on the host path it had /tv and on the container path it had nothing and was makre dread only.
i changed that entry to have /mypath/tothetv/folder/TV and the container side have /tv and that seems to have stopped the errors.
I’ll update in a day or so to see if it has properly fixed it.


#7

yup, that seems to have fixed it.