Season Pass custom filter not working

Sonarr Version:
Mono JIT compiler version:
Debian GNU/Linux 9, Deepin 15.11

Description of issue:

Season Pass custom filter (root folder path) isn’t working for me.
Not sure what I could be doing wrong, seems straightforward…
I tried adding a custom filter for a root folder path exactly as it appears on the Series pages:

Label _____ KarlTV
Root Folder Path _____ is _____ /mnt/Main/Media/Karl/TV/

then saved it.

When the KarlTV custom filter is selected in Season Pass, only one series is listed, out of many, many series that are there. The only thing I can see that’s unique about this one show is that it was the last series I added.

I create a custom filter for another root folder path. It’s a somewhat smaller library,

Label _____ JimTV
Root Folder Path _____ is _____ /mnt/Ultra/Media/Jim/TV/

When the JimTV filter is selected in Season Pass, four shows are listed. Again, nothing unique that I can see about those four, out of the many shows that are under that folder and that should be showing up too. And none of these four are newly added shows in this case.

Am I missing something?

Do those root folders exist within in Settings: Media Management: Root Folders (with that exact casing)?

Since series don’t link directly to a root folder the root folder is calculated based on the existing root folders and failing that it becomes the parent path of the series folder, which may not be correct is series folders are within a folder for the starting letter, by year or something else.

Yes. To be certain I just copied & pasted the root folder path directly from Settings: Media Management: Root Folders to the filter’s Root Folder Path field. (It was exactly as I had it before). No results coming up at all now, instead getting “All series are hidden due to the applied filter”.

And the series have that exact path under the Path column? This filter is working as expected for me so it seems like Sonarr isn’t able to calculate the expected root folder.

Yes, I’m using the exact path (and casing) as the Path I see when I Edit the series – not including the series title itself …
so for the filter I’m using /mnt/Main/Media/Karl/TV/
not /mnt/Main/Media/Karl/TV/Madworld/

I wonder if it has to do with my permissions. But Sonarr has no problem otherwise creating, accessing, and deleting folders and files as needed under Karl/TV and Jim/TV.

What if you leave the trailing / off?

Permissions shouldn’t be a problem, it doesn’t have to be able to access it.

Well, I could have sworn i tried it both ways. In fact I seem to remember it putting the trailing slash in automatically if I didn’t put it in. But not sure now.

In any case, its working fine now WITH the trailing slash (not without).
They’re not all there though, only 28 out of 64 series actually located in that path. I’ll have to examine that closer tomorrow and see why that might be.

Update: I reloaded the chrome window (for Season Pass page) and instantly got the message “All series are hidden due to the applied filter” again, and no lists displaying for either of the filters I just had working (albeit incomplete lists). Closed and reopened Sonarr window (not server restart) and same. Restarted service and same. Re-entered the path, deleted and re-entered the filter, all the same, no list.

The custom filters I created for Series using “contains” and the root paths continue to work fine. Lists are correct and complete for them. I’ll look more into this tomorrow and see what I can find.

With or without the trailing / , same, All hidden message.

This morning I went to the Season Pass page and it was displaying the (incomplete) list again! But when I reloaded the page it immediately went back to displaying the All hidden message, with no intervening changes except me reloading the page. Trailing / was in. I tried again without the trailing / and no change, so for now its back in.

I thought maybe it has to do with one of the hard drives being an external usb3 hard drive that takes a few seconds to spin up. The other is an internal SATA WD Black. So I made sure both drives were accessing folders and files and went back to the Season Pass page and with my custom filter selected reloaded the page. Still the same All hidden message with either filter. Rebooted the computer too, and same message.

So that’s where I’m stuck now. Not sure what makes the custom filters work again when they do, maybe an automatic Sonarr housekeeping step? In any case reloading the page has now twice caused the page to immediately revert back to the All hidden message.

Update: Manually excecuted System Tasks: Refresh Series and Housekeeping. No change.

Looking at the response from the API for /api/v3/series and comparing when it works and when it doesn’t is my only suggestion right now.

ok I’ll keep an eye on it. thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.