Refresh series - Stuck?

Version 3.0.3.664
Mono 5.20.1.19

Running on Qnap TS-1277 with latest firmware
Things have not been running smoothly as several series are not being updated

sonarr%20refreshCapture

I noticed this under tasks

Refresh , stop, start, restart - tried em all and i still it says its been 17 days since "last execution"

And currently have tried updating to 3.0.3.679 several times but fails every time.

Going to need at least the debug logs, trace logs would be helpful too.

logs x2

Thanks for the fast replay

Coincidence ? I don’t think so.

It has 17 (18 now) days since my Ray Donovan problem that caused a total re-install !!

So that means no series refresh since that install !

Right now things are just stalled out and nothing meaningful is in the logs, can you do this:

  1. Clear the log files
  2. Restart Sonarr
  3. Grab the trace logs after a few minutes
  4. Post logs

PS, post the logs separately if posting more than one.

http://paste.ubuntu.com/p/SYzj9nnnS4/plain/

Thanks

I’m unable to view the logs, I’m directed to a login page.

https://paste.ubuntu.com/p/R3Twj9Gh8j/

This one ?

Looks like refresh series is running through properly.

20-1-6 21:03:32.7|Info|RefreshSeriesService|Updating City on a Hill
20-1-6 21:03:33.1|Info|RefreshEpisodeService|Starting episode info refresh for: [356672][City on a Hill]
20-1-6 21:03:33.2|Info|RefreshEpisodeService|Finished episode refresh for series: [356672][City on a Hill].
20-1-6 21:03:33.2|Info|DiskScanService|Scanning City on a Hill

since it’s not completing at some point it may be stalling out, finding when it stalls will be the next step, for that you can use the Info logs and once a time is found diving into the trace/debug logs will give more information on the why.

Refreshing will log in a couple different ways depending if the series ended more than 30 days ago or not.

Continuing will log like this:

20-1-6 21:01:53.6|Info|RefreshSeriesService|Updating Barry
20-1-6 21:01:54.5|Info|RefreshEpisodeService|Starting episode info refresh for: [333072][Barry]
20-1-6 21:01:54.5|Info|RefreshEpisodeService|Finished episode refresh for series: [333072][Barry].
20-1-6 21:01:54.6|Info|DiskScanService|Scanning Barry
20-1-6 21:01:54.6|Info|DiskScanService|Completed scanning disk for Barry

Ended will log like this:

20-1-6 21:01:54.7|Info|RefreshSeriesService|Skipping refresh of series: Barry'd Treasure
20-1-6 21:01:54.7|Info|DiskScanService|Scanning Barry'd Treasure
20-1-6 21:01:54.7|Info|DiskScanService|Completed scanning disk for Barry'd Treasure

Thanks for all your help Marcus but have started again from scratch.

A post was split to a new topic: Timeout connecting to Skyhook

Ok new install and still having issues with Ray Donovan (and probably others)
After install updated to 3.0.3.687
And refresh runs 24/7 .

I have all RD but Sonarr shows none. I have moved RD and then deleted from Sonarr and started again and download everything again. “Refresh and Scan” runs non stop. Stopped and shutdown does nothing.

And System / Health has Hundreds of titles (maybe all) "were removed from The TVDB"
Attached trace debug etc

Sonarr txt

Need debug logs of the rescan to investigate and a directly listing (ls -la) from the RD folder.

Lots of threads and a pinned topic on this.

My previous Sonarr. txt

has DEBUG, TRACE and sonarr .

here is a new one - just debug

deBUG

As I said before please upload them separately, scrolling down to find a differently log file is unnecessary.

The only thing I see for Ray Donovan is this:

20-1-12 00:20:27.3|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: /share/CACHEDEV2_DATA/Media/backup/finished/Ray.Donovan.S01E01.720p.HDTV.x264-EVOLVE. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

Permissions is the typical cause.

As I said before please upload them separately, scrolling down to find a differently log file is unnecessary.

I hear you but thought the find option in your browser makes it pretty easy to find names/words :smiley:

I have changed permissions, removed and reinstalled and tried with seasons and without seasons

ATM All the files are in the folder AND in seasons (both) and Sonarr is showing all missing.
I am now deleting RD folder - rebooting everything then add it again - for the x time

A debug log of a refresh/rescan of the RD folder will show you exactly which files Sonarr sees in the folder.

Do an ls -la for RD and a series where Sonarr can see all the files. Compare the results (owner and permissions).

If they’re there already deleting them and re-adding them may change something, but fixing the underlying issue should as well.

Which filesystem are you using on the QNAP?

I am using Qnap 4.4.1.1146
File system is the default

Finished re download
media/tv/Ray Donavan shows all episodes from 7 series.
Sonarr shows every season empty !

permissions same as every other show/folder

Plex shows and plays them

What’s the default file system?

QNAP uses the ext4 file system.

It’s been 10days since i did the fresh install.

Going by this Refresh Series last happened 10 days ago.
The rotating arrow (refreshing) does not stop !!
All others have stop after the “restart”
This is the original problem.
Let’s forget about RD ( still not showing ) as this appears to be the fault