RARBG indexer not working


#1

Sonarr Version 2.0.0.5301
Windows Server 2012 R2

RARBG indexer not working.
LOGS: https://pastebin.com/iZGt44Uy

It has been working for a whole week until it this morning (without any change) it just gives me this error.
One post said switching the API URL from “https://torrentapi.org” to “http://torrentapi.org” worked but it didn’t for me.
Shouldn’t be DNS problem because it has worked before. I use 1.1.1.1 and 1.0.0.1 DNS and nslookup for torrentapi.org works just fine. I’m also able to ping the addresses that it returns to me.
Even “http://torrentapi.org” lands me on webpage.
https://torrentapi.org/pubapi_v2.php?get_token=get_token” doesn’t though…

While I was writing this I tried adding the RARBG on Jackett so I can then add jackett on sonarr but apparently https://torrentapi.org isn’t responding to jackett either.
Can anyone confirm if https://torrentapi.org/ is up or down ?


#2

I am having this same problem. Using 1.1.1.1 or google’s 8.8.8.8 hasn’t changed anything either.


#3

After changing your DNS settings, did you clear any DNS caches? I had a similar issue, with the torrentapi.org domain resolving to a parking page. Changing my DNS to the cloudflare DNS resolves it to cloudflare, and the indexer is accessible again.


#4

DNS has been cloudflare’s since forever (1+ year) and just to be sure, yes, I just cleared DNS cache and still the same issue.

torrentapi.org might be down I guess


#5

Strange. They might be having DNS issues - as soon as I switched to the cloudflare DNS, it started working for me (about 3 minutes before my post above).


#6

It’s down for me too, and I’m using Cloudflare DNS’s.
What IP addresses are you guys getting for torrentapi.org?


#7

Name:
torrentapi.org
Addresses:
198.54.117.197
198.54.117.198
198.54.117.199
198.54.117.200


#8

Yeah, I’m getting the same addresses @onvrb.
Just different order.


#9

So… A few hours has passed and when I went on trying to open https://torrentapi.org/pubapi_v2.php?get_token=get_token on a web page, a 403 Forbidden error comes up. This means it’s working I guess. I went on Sonarr and retried testing the indexer and it worked just fine.
I guess the problem was with them…

@ThatWhiteMonster give it a try now.


#10

Yeah, looks like it’s working now :slight_smile: .
Thanks for the heads up, @onvrb .


#11

maybe your IP was banned at rarbg.to, as you hammered their server, or something like that.


#12

@alneven - In my case, I don’t think so :wink: .

Also, I’ve noticed that event though search works, you can’t go to the release page from the manual search link - it gives you 403 error. But adding the release to the queue works. No idea why the link doesn’t work though . . .