Problems importing files from NZBGet

Sonarr version (exact version): 3.0.6.1343
Mono version (if Sonarr is not running on Windows): 5.20.1.34
OS: Synology DSM 6.2.4-25556 Update 2
Debug logs: https://hastebin.com/osociyozov.rb
Description of issue:
I’m getting a permissions error when trying to import files previously downloaded by NZBGet

I’ve checked the file permissions, both from the command line and from the DSM web interface, and despite setting the file permissions to 777, I’m still getting this error.

If anyone can suggest why, I’d appreciate it!

Output from directory listing, showing the file permissions:

root@PlexStation:/# ls -la /volume2/Downloads/AutoDownloads/tv/The.Great.British.Bake.Off.An.Extra.Slice.S08E02.1080p.HEVC.x265-MeGusta
total 677780
drwxrwsrwx  1 Neil        sc-download       152 Oct  3 20:03 .
drwxrwxr-x+ 1 sc-nzbdrone sc-download       320 Oct  3 20:03 ..
-rwxrwxrwx  1 Neil        sc-download 694042986 Oct  3 20:03 The.Great.British.Bake.Off.An.Extra.Slice.S08E02.1080p.HEVC.x265-MeGusta.mkv

Basic ownership and permissions is the issue.

Synology makes it very difficult to do these right due to ACLs and the apps are frequently out of date and not updated along with being a pain to configure

OK. Well, the file has no ACL, as can be seen by the lack of a + in the ls listing, but also verified with the synoacltool command. None of the directories above the file have ACLs either, and have 775 permissions.

The file ownership is Neil:sc-download

Sonarr is running as the sc-nzbdrone user, which is a member of the sc-download group.

The file has 777 as its permission.

The Sonarr App updates itself, and is currently at the latest version (3.0.6.1347).

So what am I missing?

Just because the sonarr user is part of the group does not mean it is running as the group

But the Sonarr team does not maintain the NAS packagers; perhaps SynoCommunity will be of more help for Syno specific issues

OK. But the file has no ACLs, and has W:RWX privilege - so the Group should not matter anyway.

The NAS package is only used for the initial install. Beyond that, the App updates itself from the Github repository, so it seems unlikely that the SynoCommunity will do anything except advise me to ask on the Sonarr Support forum!

But I’ll try it anyway, since it seems I’m not going to get much help here.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.