PMS Connection Not Working When Secure Connections Are Required In Plex


#1

Sonarr version (exact version): 3.0.1.441
Mono version (if Sonarr is not running on Windows): 5.20.1.19
OS: Docker
Debug Logs: https://pastebin.com/raw/eNA26abG
Description of issue: Connections to PMS do not work when Plex is set to require secure connections. I’ve added my debug log but removed my client id and token from the URL.

Note: I am using the default Plex cert, I am not using my own certificate in Plex. Someone else is not having this issue using their own cert. I suspect this might have to do with the URL formatting, it does not appear to use the plex direct address when I have it set to required.

Steps taken:

  1. Open PMS connection configuration modal (change nothing)
  2. Test with Plex set to preferred, no issues
  3. Change Plex to required
  4. Test again, fails

#2

You need to tell Sonarr to connect over https… with Use SSL in Sonarr’s PMS settings. If you use localhost or 127.0.0.1 the certificate validation will fail unless you turn off certificate validate for local addresses in Sonarr.


#3

I tried that but had the same issues. I’ve tried using the actual server IP of 192.168.0.10 as well as the internal container IP in Docker of 172.17.0.1. Both with and without SSL still fails.

I have not tampered with certificate validation in Sonarr but based on your answer it seems like I shouldn’t have to for my test cases.


#4

Unless you’re using a valid hostname that is listed in the certificate you will need to disable certificate validation for local addresses.


#5

Was there a update recently in Sonarr that changed this behavior? I’m fine with making these changes I just didn’t need them previously.

Edit: Just as a follow up I’ve done what you’ve said and it worked.


#6

Yes, that changed a few weeks ago in the v3 alpha.


closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.