Plex connection shows disabled


#1

Sonarr version (3.0.1.408):
Mono version (if Sonarr is not running on Windows):
OS: Windows 10
((https://drive.google.com/file/d/1pCM6OT0IZlv-vEMHi3iJZrkvCuXPB67l/view?usp=sharing)):
This is the first time I’ve tried sharing with Google Drive so please bear with me if something is wrong.
Description of issue:
Under Settings/Connect, added the Plex authorization token to restore my previously defined connection to Plex. Did NOT select On Grab, On Import, or On Rename but did check the box to update library.

Connection box shows as disabled without one of the three boxes noted above checked.
The log file seems to say that the authorization token that Sonarr got from Plex isn’t valid…


#2

If you don’t select On Import/ On Rename then the update library would never run, but that won’t cause the token to fail.

Either the token is invalid and you’ll need a new one or it’s not authorized to talk to that endpoint (server is owned by another user for example).
Have you tried authenticating again?


#3

One thing I didn’t mention before was that a Test of the connection succeeded even when the log said Authorization error when none of those options were selected. I did go back and try to reauthorize but got the same token back from Plex.

I went back and selected On Import, On Rename, and On Upgrade but On Grab is greyed out.

I also forced a rename which generated an error in the log. The log on Google Drive has been updated.

And Plex is updating when a show episode is added now.


closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.