Permission don't stick in User interface


Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue:
Sonarr Version
Mono Version
Freenas 11.1 U2
If I set in Media Mangement/Permissions the File chmod mask to 660 and Folder chmod mask to 770, the folder get the correct Permission but the file is 666 after a restart of sonarr. I want the group to have write permissions so I can delete files from plex which is a member of media group like sonarr which also is a member of media. No read/write/execute permission for other.

18-3-11 19:20:50.3|Warn|MediaFileAttributeService|Unable to apply permissions to: /mnt/media/videos/tvshows/TV Show

[v2.0.0.5153] NzbDrone.Mono.Disk.LinuxPermissionsException: Error setting file owner and/or group: EPERM
at NzbDrone.Mono.Disk.DiskProvider.SetOwner (System.String path, System.String user, System.String group) [0x00056] in :0
at NzbDrone.Mono.Disk.DiskProvider.SetPermissions (System.String path, System.String mask, System.String user, System.String group) [0x00008] in :0
at NzbDrone.Core.MediaFiles.MediaFileAttributeService.SetMonoPermissions (System.String path, System.String permissions) [0x0002d] in <907396538063488ebd3918dbee5833ec>:0

18-3-11 19:20:50.3|Warn|MediaFileAttributeService|Unable to apply permissions to: /mnt/media/videos/tvshows/TV Show/Season 8


EPERM means the user running Sonarr doesn’t have permissions to change the owner and or group. Make sure you’re not trying to give the files away, by making the owner a different user, only the root user can do that and Sonarr shouldn’t be run as root.


Is it recommend to leave the permissions as the default re: user:sonarr group:media or change the user of sonarr to media so plex can delete files?


The defaults will depend on the system, either should work though.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.