Override search term?


#1

Sonarr version (exact version): 3.0.1.467
Mono version (if Sonarr is not running on Windows): Windows
OS: Windows 10 64-bit
Debug logs: N/A, not a technical issue per se
Description of issue: Hi, I’m trying to get Sonarr to download the currently airing Dororo anime, but since the database (TVDB?) has the title set as Dororo (2019) to avoid conflicts with the older 1969 show it searches indexers for “Dororo 2019”. The problem is that all the releases are simply titled “Dororo” so they all get rejected and I can’t download anything. Is there a way to override the naming / search term used by Sonarr so I can download the show?

Thanks!

EDIT:
A related problem: It seems to search for English show titles when the standard for Anime is to use the Japanese titles, so the show Senryuu Shoujo makes a request for “Senryu Girl” which returns no results. This also would be easily solved if I could change the name or something similar. Thanks again for any help!

EDIT 2:
I found this Github issue which suggests Sonarr should automatically grab the Japanese name from http://thexem.de/, and the show is on there, but it’s still making a request to https://nyaa.si/?page=rss&c=1_2&f=1&term=Senryu+Girl+1 instead of https://nyaa.si/?page=rss&c=1_2&f=1&term=Senryuu+Shoujo+1. The show is set as an anime and using the Japanese name definitely should produce results.

Dororo (2019) is also aliased to Dororo on xem so really I think my problem is simply that xem isn’t being used?


#2

Did you set the series type to anime in sonarr?

Edit: disregard, I read of the fact that you did.


#3

Hmm. couple of things.

  1. Do a search with Debug logging on. If I search for an episode (Say episode 3) Sonarr searches for both Dororo 2019 03 and dororo 03. (and when I do an automatic search, it grabs a release without the year.)
  2. Basically same comment for Senryu Girl vs. Senryuu Shoujo. Logs search for both and grabs whatever best meets my settings.

If you could post a debug log of a search we may be able to help you further


#4

Thanks for the reply, but it seems to have started working on its own :confused:
I’m doing everything exactly the same as yesterday, but today it’s making both searches as you suggest it should. I wonder if it was having trouble connecting to xem yesterday or something.


#5

Glad to hear it is working again.

Who knows. Could be a caching issue, network issue, or some other weirdness (I have often wondered if having the scene mapping updates every 3 hours and the series refresh every 12 hours causes any of these types of things, so I have a tendency to run each of them manually when I am running manual searches for currently a running series).


#6

I’m having the same issue, however mine has not appear to have fixed itself. This is the second time I’ve tried adding this show, and neither time has worked. When I look at the logs in sonarr, the only thing it searches for is [Dororo (2019) : S01E01]. Is there any configuration I have to do to set up xem, or should it just work out of the box?