Organize doesn't pick up original filename

Sonarr version (exact version): 3.0.9.1549
Mono version (if Sonarr is not running on Windows): 6.12.0.182
OS: Ubuntu 22.04 LTS
Debug logs: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
Description of issue:
My naming convention includes the Original Title of the file: {Series Title} - S{season:00}E{episode:00} - [{Original Title}]
When importing downloads automatically or manually from another directory, the files are renamed correctly, but when using the Organize feature for already mapped files, the Original Title is blank:

Looks like it is trying to rename to multi-episode format? Eg. going from S04E11 to S04E37-E40

That’s probably throwing it off since I’m guessing the logic may think there is more than one original title at that point and therefore there is no single value to use. That’s my guess anyway.

What happens if you try on a series that is doing a one-to-one rename?

I tried on a few random series of mine, and all of mine worked as intended, carrying over the Original Title as the current existing title.

Interesting theory, but this only happens on this particular screen. If I import the files from Manual Import on the Wanted screen, they are renamed properly. It is only the Organize screen that it happens on. I have confirmed that what is shown is actually what it is renamed to (rather than a UI error)

Sounds like Sonarr doesn’t know the original name for the existing episodes so it’s not able to include it, but during import it can because it knows the original file name.