No image while adding series


#1

Is it normal that there is no image shown when searching a new show before adding it? In radarr it does show coverart, but I sonarr I can’t see it on different machines. Once added it does show the picture.

So is it working as intended or is something wrong?


#2

They should be shown, what do the debug logs show?


#3

Do you need the full debug log? Cause I’ve looked through it and I can’t find anything other then the processing of files. And I don’t want to waste your time with full logs with no useful info.

For this example I’ve searched for “Highlander” and only see this happening in the debug log:
18-8-8 21:06:47.2|Debug|Api|[GET] /api/series/lookup?term=highlander: 200.OK (211 ms)

The trace log shows this:
18-8-8 21:12:46.6|Trace|Http|Req: 300 [GET] /api/series/lookup?term=highlander
18-8-8 21:12:46.6|Trace|HttpClient|Req: [GET] http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=highlander
18-8-8 21:12:46.6|Trace|ConfigService|Using default config value for ‘proxyenabled’ defaultValue:‘False’
18-8-8 21:12:47.0|Trace|HttpClient|Res: [GET] http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=highlander: 200.OK (453 ms)
18-8-8 21:12:47.0|Trace|Http|Res: 300 [GET] /api/series/lookup?term=highlander: 200.OK (459 ms)
18-8-8 21:12:47.0|Debug|Api|[GET] /api/series/lookup?term=highlander: 200.OK (459 ms)

I’m using pi-hole but whitelisted all the sonarr links mentioned online. And I’ve also tested with pi-hole off (restarted sonarr after) and still the same result.


#4

Ahh, those images are loaded directly from TheTVDB (for the search results).

http://www.thetvdb.com/banners/posters/75160-4.jpg which redirects to https://www.thetvdb.com/banners/posters/75160-4.jpg is what I’m seeing used for the first result.


#5

That was the problem indeed. When I whitelisted thetvdb.com in pi-hole it instantly started showing the images. It’s weird though, The page did not show up in the pi-hole query logs. Plus I’m not running heavy blocklists and with pi-hole disabled it still didn’t work. Could be some DNS caching issue of course.

Anyways it’s working fine now, thanks for the support :slight_smile:.