New Sonar Install in Docker on Synology - Searching not working


#1

Sonarr version (exact version): 2.0.0.5301
Mono version (if Sonarr is not running on Windows): 5.18.0.240
OS: Synolofy DSM 6.2
Debug logs:
Description of issue: Unable to search for anything. Getting " There Was An Error Searching For “tv show name” "

Really need some help here. If anyone that is running Sonar in Docker on a Synology that can help.
I tried search for example for Flash and getting the “error searching…”

The tracelogs shows it tried http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
There is also a /api/series/lookup?term=flash: 503.ServiceUnavailable in the log.

I did a curl on my synology and it reached it fine. “curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash” also tested in in browser…good results.

So for the life of my I can’t figure out why its not work from the Sonar GUI. I checked the proxy…its set to NO.

Has anyone have this problem? Help!!

Sonarr.Trace.Txt
19-2-5 22:35:08.2|Trace|ConfigService|Using default config value for ‘proxyusername’ defaultValue:’’
19-2-5 22:35:08.2|Trace|ConfigService|Using default config value for ‘proxypassword’ defaultValue:’’
19-2-5 22:35:08.2|Trace|ConfigService|Using default config value for ‘proxybypassfilter’ defaultValue:’’
19-2-5 22:35:08.2|Trace|ConfigService|Using default config value for ‘proxybypasslocaladdresses’ defaultValue:‘True’
19-2-5 22:35:08.2|Trace|EventAggregator|ConfigFileSavedEvent <~ ReconfigureLogging
19-2-5 22:35:08.2|Trace|Http|Req: 67 [GET] /api/health
19-2-5 22:35:08.2|Trace|Http|Res: 66 [PUT] /api/config/host: 202.Accepted (106 ms)
19-2-5 22:35:08.2|Debug|Api|[PUT] /api/config/host: 202.Accepted (106 ms)
19-2-5 22:35:08.2|Trace|Http|Res: 67 [GET] /api/health: 200.OK (10 ms)
19-2-5 22:35:08.2|Debug|Api|[GET] /api/health: 200.OK (10 ms)
19-2-5 22:35:08.2|Trace|EventAggregator|ConfigSavedEvent <~ TaskManager
19-2-5 22:35:08.2|Trace|Http|Req: 68 [GET] /api/health
19-2-5 22:35:08.2|Trace|Http|Res: 68 [GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:08.2|Debug|Api|[GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:10.6|Trace|Http|Req: 69 [GET] /api/series?sort_by=sortTitle&order=asc
19-2-5 22:35:10.6|Trace|Http|Res: 69 [GET] /api/series?sort_by=sortTitle&order=asc: 200.OK (37 ms)
19-2-5 22:35:10.6|Debug|Api|[GET] /api/series?sort_by=sortTitle&order=asc: 200.OK (37 ms)
19-2-5 22:35:11.8|Trace|Http|Req: 70 [GET] /api/profile
19-2-5 22:35:11.9|Trace|Http|Req: 71 [GET] /api/rootfolder
19-2-5 22:35:11.9|Trace|Http|Res: 70 [GET] /api/profile: 200.OK (11 ms)
19-2-5 22:35:11.9|Debug|Api|[GET] /api/profile: 200.OK (11 ms)
19-2-5 22:35:11.9|Trace|Http|Res: 71 [GET] /api/rootfolder: 200.OK (19 ms)
19-2-5 22:35:11.9|Debug|Api|[GET] /api/rootfolder: 200.OK (19 ms)
19-2-5 22:35:14.7|Trace|Http|Req: 72 [GET] /api/series/lookup?term=flash
19-2-5 22:35:14.7|Trace|HttpClient|Req: [GET] http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
19-2-5 22:35:14.8|Trace|ConfigService|Using default config value for ‘proxyenabled’ defaultValue:‘False’
19-2-5 22:35:15.0|Trace|HttpClient|Res: [GET] http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash: 302.Redirect (216 ms)
19-2-5 22:35:15.0|Trace|NzbDroneErrorPipeline|Handling Exception
19-2-5 22:35:15.0|Trace|Http|Res: 72 [GET] /api/series/lookup?term=flash: 503.ServiceUnavailable (301 ms)
19-2-5 22:35:15.0|Debug|Api|[GET] /api/series/lookup?term=flash: 503.ServiceUnavailable (301 ms)
19-2-5 22:35:22.8|Trace|Http|Req: 73 [GET] /api/health
19-2-5 22:35:22.8|Trace|Http|Res: 73 [GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:22.8|Debug|Api|[GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:22.9|Trace|Http|Req: 74 [GET] /api/diskspace
19-2-5 22:35:22.9|Trace|ConfigService|Using default config value for ‘downloadedepisodesfolder’ defaultValue:’’
19-2-5 22:35:22.9|Trace|Http|Req: 75 [GET] /api/health
19-2-5 22:35:22.9|Trace|Http|Res: 75 [GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:22.9|Debug|Api|[GET] /api/health: 200.OK (2 ms)
19-2-5 22:35:23.0|Trace|Http|Res: 74 [GET] /api/diskspace: 200.OK (137 ms)
19-2-5 22:35:23.0|Debug|Api|[GET] /api/diskspace: 200.OK (137 ms)
19-2-5 22:35:23.0|Trace|Http|Req: 76 [GET] /api/diskspace
19-2-5 22:35:23.0|Trace|ConfigService|Using default config value for ‘downloadedepisodesfolder’ defaultValue:’’
19-2-5 22:35:23.1|Trace|Http|Res: 76 [GET] /api/diskspace: 200.OK (132 ms)
19-2-5 22:35:23.1|Debug|Api|[GET] /api/diskspace: 200.OK (132 ms)
19-2-5 22:35:27.0|Trace|Http|Req: 77 [GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc
19-2-5 22:35:27.1|Trace|Http|Res: 77 [GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (6 ms)
19-2-5 22:35:27.1|Debug|Api|[GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (6 ms)
19-2-5 22:35:27.1|Trace|Http|Req: 78 [GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc
19-2-5 22:35:27.1|Trace|Http|Res: 78 [GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (5 ms)
19-2-5 22:35:27.1|Debug|Api|[GET] /api/log?page=1&pageSize=50&sortKey=time&sortDir=desc: 200.OK (5 ms)
19-2-5 22:35:28.8|Trace|Http|Req: 79 [GET] /api/log/file
19-2-5 22:35:28.8|Trace|Http|Res: 79 [GET] /api/log/file: 200.OK (5 ms)
19-2-5 22:35:28.8|Debug|Api|[GET] /api/log/file: 200.OK (5 ms)
19-2-5 22:35:28.8|Trace|Http|Req: 80 [GET] /api/log/file/sonarr.trace.txt
19-2-5 22:35:28.8|Trace|Http|Res: 80 [GET] /api/log/file/sonarr.trace.txt: 200.OK (3 ms)
19-2-5 22:35:28.8|Debug|Api|[GET] /api/log/file/sonarr.trace.txt: 200.OK (3 ms)
19-2-5 22:35:30.1|Trace|Http|Req: 81 [GET] /api/log/file/sonarr.trace.txt
Sonarr Ver. 2.0.0.5301


#2

it could also just be a temporary issue, ive seen it do that then come good later

you can run curl from inside the container to confirm that it can actually get out (unless thats what you meant by running from synology?)

telnet (ssh) to your nas
login as admin
sudo -i
enter the admin password, it will probably fail the correct password here, just enter it again
docker exec -it sonarr bash

if you called your container something else change sonarr to that name

then run curl from in there to make sure it actually works

im using the linuxserver/sonarr image and not having any issues, which image are you using?


#5

Thanks rhom for the reply.
I did the curl when I logged into the Synology but not from in the container. I will try your docker command when I get a chance.
Yes, the linuxserver/sonarr (latest) is the image i am using.

So I tired the curl in the container. I don’t think that is the response I should be getting. Tried it again in the general synology volume1 (outside the container). It looked the same so my initial confirmation of curl working was maybe incorrect. The link is working because it shows up fine in a browser.

Would you be able to do a curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash in your container to see the response you get?

`Preformatted text`root@linuxserver-sonarr1:/# curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><head><meta http-equiv="content-type" content="text/html; charset=UTF-8"><link href="/css/basic.css" title="Main" type="text/css" rel="stylesheet"><link href="/css/tabs.css" title="Main" type="text/css" rel="stylesheet"><title>Error</title></head><body><div id="container"><h1 id="logo_uverse"></h1><div id="header"></div><div id="main"><div id="outercontainer"><div id="header2"></div><div id="innercontainer"><div id="contents"><a href="http://attlocal.net/xslt?PAGE=HURL08"><h2>Found</h2> <p>Found</p></a></div></div></div></div></div></body></html>//"

I also tried testing the connection to my indexer from the GUI and that works fine.

So I am at a lost whey the search doesn’t work. Tried several times since yesterday.


#6

That request shouldn’t redirect at all. Based on the output of curl it looks like your ISP is redirecting the request to their own server. Probably worth switching to another DNS server.


#7

How can you tell?

Just to rule out the DNS redirect, I also tested from my laptop on the same home network and it works fine.

C:\WINDOWS\system32>curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
[{“tvdbId”:78650,“title”:“The Flash”,“overview”:“Central City Police forensic scientist Barry Allen’s crime lab is struck by lightning. Allen’s electrified body is flung into and shatters a cabinet of chemicals, which are both electrified and forced to interact with each other and with his physiology when they come into physical contact with his body. He soon discovers that the accident has changed his body’s metabolism and as a result he has gained the ability to move at superhuman speed. \nBarry Allen has become the Flash.”,“slug”:“the-flash”,“firstAired”:“1990-09-20”,“tvRageId”:5781,“tvMazeId”:528,“status”:“Ended”,“runtime”:60,“timeOfDay”:{“hours”:20},“network”:“CBS”,“imdbId”:“tt0098798”,“actors”:[{“name”:“John Wesley Shipp”,“character”:“Barry Allen/Flash”},{“name”:“Amanda Pays”,“character”:“Christina McGee”},{“name”:“Alex Desert”,“character”:“Julio Mendez”},


#8

The HTML page that it returned has a link that points to http://attlocal.net/xslt?PAGE=HURL08


#9

hmmm…nslookup for that url is my ATT router’s gateway. 192.168.115.1

nslookup attlocal.net
Server: homeportal
Address: 192.168.115.1

Name: attlocal.net.attlocal.net
Address: 192.168.115.1

Did the curl test on my laptop and it works fine.

C:\WINDOWS\system32>curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
[{“tvdbId”:78650,“title”:“The Flash”,“overview”:“Central City Police forensic scientist Barry Allen’s crime lab is struck by lightning. Allen’s electrified body is flung into and shatters a cabinet of chemicals, which are both electrified and forced to interact with each other and with his physiology when they come into physical contact with his body. He soon discovers that the accident has changed his body’s metabolism and as a result he has gained the ability to move at superhuman speed. \nBarry Allen has become the Flash.”,“slug”:“the-flash”,“firstAired”:“1990-09-20”,“tvRageId”:5781,“tvMazeId”:528,“status”:“Ended”,“runtime”:60,“timeOfDay”:{“hours”:20},“network”:“CBS”,“imdbId”:“tt0098798”,“actors”:[{“name”:“John Wesley Shipp”,“character”:“Barry Allen/Flash”},{“name”:“Amanda Pays”,“character”:“Christina McGee”},{“name”:“Alex Desert”,“character”:“Julio Mendez”},

Since the curl for that url also gets the funky response when running it outside of the container on the Synology. It leads me to believe it has to be something with the skyhook server.
So I tested doing a curl to something else, both in the container and out…and they work just fine. curl to the Synology forum…just captured the first few lines.

root@linuxserver-sonarr1:/# curl https://forum.synology.com/enu/index.php

Synology Forum - Index page
    <link rel="alternate" type="application/atom+xml" title="Feed - Synology Forum" href="/enu/app.php/feed">               <link rel="alternate" type="application/atom+xml" title="Feed - All forums" href="/enu/app.php/feed/forums"> <link rel="alternate" type="application/atom+xml" title="Feed - New Topics" href="/enu/app.php/feed/topics"> <link rel="alternate" type="application/atom+xml" title="Feed - Active Topics" href="/enu/app.php/feed/topics_active">

    phpBB style name: Flat Style
    Based on style:   prosilver (this is the default phpBB3 style)
    Original author:  Tom Beddard ( http://www.subBlue.com/ )
    Modified by:      Ian Bradley

So what is it about the call to the skyhook server that is causing this issue from the Synology?


#10

That points to an issue with the synology setup to me, if it was a server issue we’d be seeing thousands of reports and you’d have a consistent result with other devices on your network.


#11

I would agree with you but it doesn’t explain why the curl to the skyhook still doesn’t work outside of the container. My last course of action is to wipe out the container and docker and start over. Will test the curl to the url again before installing docker and sonarr.

thx


#12

It points to an issue with the DNS on the synology, not something within the container, I’d verify the settings for that before going nuclear and try another DNS server (other than your ISP’s), maybe google or cloudflare.


#13

The Synology was getting its DNS from my router. Changed it to Google. No different.

root@WEST-NET:~# nslookup

skyhook.sonarr.tv
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: skyhook.sonarr.tv
Address: 104.25.52.107
Name: skyhook.sonarr.tv
Address: 104.25.51.107

exit

root@WEST-NET:~# curl http://skyhook.sonarr.tv/v1/tvdb/search/en/?term=flash
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><head><meta http-equiv="content-type" content="text/html; charset=UTF-8"><link href="/css/basic.css" title="Main" type="text/css" rel="stylesheet"><link href="/css/tabs.css" title="Main" type="text/css" rel="stylesheet"><title>Error</title></head><body><div id="container"><h1 id="logo_uverse"></h1><div id="header"></div><div id="main"><div id="outercontainer"><div id="header2"></div><div id="innercontainer"><div id="contents"><a href="http://attlocal.net/xslt?PAGE=HURL08"><h2>Found</h2> <p>Found</p></a></div></div></div></div></div></body></html>
root@WEST-NET:"

#14

Absolutely not a Sonarr issue.

Likely just your router acting up. Google is filled with ppl running into router-behind-router detection in the at&t router log for that specific url. I suggest you use those resources to pinpoint and resolve your issue.


#15

Thanks. I will look into that also. What is it about that url that triggers that issue and not for others when originated from the Synology. The curl to that url works just find from my laptop.


#16

Except that docker uses an NAT to deal with container network communications. so it IS a router-behind-router. So it is different in the docker container vs your laptop. And it’s even different for different containers. And the router-behind-router detection logic is a black box, we don’t know the criteria that triggers it.
Regardless, all the information you gathered thus far points squarely at your internet router.


#17

Wow that was painful. Thanks for assisting with the background knowledge on this issue that can affect the URL when called from a docker container . After eliminating everything I could thing off that seems to have done the trick. Took me a min to dig for that option on the ATT router.
Thanks again guys.


closed #18

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.