New install - root stuff

debgut log: Ubuntu Pastebin

Package Version 3.0.10 by Team Sonarr
Mono Version
AppData directory /var/lib/sonarr
Startup directory /usr/lib/sonarr/bin
Mode Console

greg@greg-desktop:~$ stat /media/3tb/TV
File: /media/3tb/TV
Size: 12288 Blocks: 24 IO Block: 4096 directory
Device: 821h/2081d Inode: 98828289 Links: 144
Access: (0775/drwxrwxr-x) Uid: ( 130/ sonarr) Gid: ( 1000/ greg)
Access: 2023-09-19 17:12:35.679376454 -0700
Modify: 2023-09-07 21:20:45.050264850 -0700
Change: 2023-09-19 17:12:11.222614107 -0700
Birth: 2023-06-01 19:56:20.169492286 -0700
greg@greg-desktop:~$ stat /media/3tb
File: /media/3tb
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 821h/2081d Inode: 2 Links: 7
Access: (0700/drwx------) Uid: ( 1000/ greg) Gid: ( 1000/ greg)
Access: 2023-09-19 14:17:59.458476114 -0700
Modify: 2023-09-05 08:58:39.745537262 -0700
Change: 2023-09-05 08:58:39.745537262 -0700
Birth: 2023-06-01 13:15:20.000000000 -0700
greg@greg-desktop:~$ stat /media
File: /media
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 802h/2050d Inode: 16121857 Links: 5
Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2023-09-19 14:41:07.355433452 -0700
Modify: 2023-09-19 14:38:29.441661208 -0700
Change: 2023-09-19 14:38:29.441661208 -0700
Birth: 2023-09-13 10:59:42.921650531 -0700

The folder that holds all shows is at /media/3tb/TV. Above is the log and my install stuff and the info on each step to the folder that holds my root folder. The TV folder is owned by sonarr and I am next.

I have this problem with regularity and have never really figured it out.; I now wonder what would happen, for instance, if I changed the mount from /media/3tb/TV to /media (root)/TV (/media/TV) thereby making TV (where the data is) actually at root/TV

My problem, now, is that I have no idea how I can mount the TV file directly to /media as it physically resides in a hard drive defined as /3tb. I couldn’t move the file to /media - no room. I will try to link it somehow. If anybody has an idea I would really appreciate it.


I linked /media/3tb/TV to /media/TV It made no difference except that sonarr did not accept /media/TV It didn’t tell me it wasn’t there and it didn’t tell me that it couldn’t deal with it. It just ignored what I had entered. The only difference was that, when I was entering the root folder, I chose /media and, then, it also let me choose TV but then ignored everything that I had entered.

So, actually putting a root folder in a root media location was no help at all and I still do not have a root folder.

If anybody can tell me how to get a root folder I would be grateful. I have no idea how to make a root folder, where to put a root folder, etc. I have a root folder but it is, simply, not acceptable to sonarr. I wonder if the name of the folder, ‘TV’ is the culprit.

I notice that I have not had anybody tell me anything. If nobody is going to respond please tell me and I will move on.

My setup is ownership of /mnt/ to myself, then I create subfolders /mnt2/

I then use chmod 777 /mnt/mnt2/Radarr/ chmod 777/mnt/mnt2/Sonarr. Then I go into Sonarr and Radarr and if I need to change my root folder I click Select Series at the top of the series or movies page then select all and go to the bottom and select edit and from there you can change the root folder.

Thank you for the reply…

Right now all my shows are in /media/3tb. Media is owner root, group root. As far as I can tell I can do the same as what you did. My problem is that I just don’t understand ‘root’. I thought that a root owner was always root and I was, obviously, wrong.

I am going to do as you did and see what happens. As far as I can tell the difference is names and ownership and nothing else changes. I kinda like your names better so I think I will change /media/3tb to /media/media2/Sonarr and /media/media2/Radarr and see what happens.

Right now, incidentally, ‘sonarr’ owns my 2 show folders and I am group (set when installed) Now I am wondering if that too should be changed.

Here is what I did.
I change the owner of /media to me
I kept the name of /media/3tb (ubuntu didn’t want me to rename)
and then made my root folder ‘Sonarr’
I then 777’d media,3tb,Sonarr, ie:

stat /media/3tb/Sonarr
File: /media/3tb/Sonarr
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: 821h/2081d Inode: 98959361 Links: 135
Access: (0777/drwxrwxrwx) Uid: ( 1000/ greg) Gid: ( 1000/ greg)
Access: 2023-09-23 09:13:59.057864161 -0700
Modify: 2023-09-22 10:05:00.024478815 -0700
Change: 2023-09-23 09:13:59.057864161 -0700
Birth: 2023-09-20 20:24:30.333494972 -0700


I then tried to enter /media/3tb/Sonarr as the root folder

I got:
Unable to add root folder
Path does not exist

So, screwed up again! What have I done wrong??

I just left me the owner of Sonarr as everything was 777’d so it made no difference (I thought)

Thanks again!

That looks to be your issue. My suggestion is to go to your distro’s forum and explain what you have happening and then either link to this thread or copy all post from this thread except this post to your thread there. If you want to copy the post to make it easier for those there who want to help you can copy my reply above with you post. Cause to be honest sounds like you’re doing everything right, but I can’t swear to it. I run Arch based distros with the Plasma desktop and I just have to add rootactions to Dolphin then rightclick in a folder I want ownership of select rootactions and from there ownership to active user.

I have magically fixed my problem!
I followed directions. My series was in /media/3tb/Sonarr. I 777 3tb AND Sonarr (every series (read, write, execute)) Overkill but trying. Then today I was looking again and in set permissions/chmod folder I change the settings to 775 and suddenly I was gifted with a root folder! AMAZING!

Just thought I would let anybody who has watched my tortured way might be interested. Hopefully I won’t be bothering everybody with my whining any more.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.