Mono Version For Latest Sonarr


#1

I know there is an issue with Mono 5.10. I installed mono and then found out about the issue after the fact. I believe somewhere there is a discussion around install Mono 5.16 instead. Unfortunately I have facing challenges installing it on my Ubuntu. The installer keeps complaining about unmet dependencies. Can someone please tell me which version I should install or direct me where in the forum I can get that information.


#2

these seems appropriate


#3

I don’t have any logs at the moment since I decide to uninstall mono and trying to figure how to install something higher in the hope that maybe the problem would be solve on version 5.18 or something. Unfortunately I have not able able to get it install.

I tried every branch I can think of. I am getting tired.

Ubuntu 17.04
EXT file system

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-runtime-sgen (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-llvm-support (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: libmono-2.0-1 (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-utils (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-devel (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-mcs (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-roslyn (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-csharp-shell (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-4.0-gac (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: mono-4.0-service (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: monodoc-base (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: monodoc-manual (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: libmono-cil-dev (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
                 Depends: referenceassemblies-pcl but it is not going to be installed
                 Depends: msbuild but it is not going to be installed
                 Depends: ca-certificates-mono (= 5.16.0.220-0xamarin4+ubuntu1804b1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.