Mass import fails: Unable to load files for Manual Import

Sonarr version (exact version): 2.0.0.5338
Mono version (if Sonarr is not running on Windows): 5.20.1.34
OS: Ubuntu 18.04 - 6 core CPU - 12GB RAM
Debug logs: https://pastebin.com/6NG0Uaxq
Trace logs: https://pastebin.com/W7Yu6ibR
Description of issue:

I tried to import a complete series (110 episodes)
didn’t work and just showed me the “Unable to load files for manual import. Check logs for more details” message

I moved the episodes into separate season folders and it failed again on season 4
I cleared the logs (like I did before, to have a suitable log to upload) and tried s04 again but it worked this time
the other seasons worked fine

is there a maximum for manual import?
I couldn’t find that information

thanks
regards

How long did it take before it failed?
Are you using a reverse proxy?

Based on the logs it looks like the request completed after 237393ms (almost 4 minutes), which is past the default timeout for most reverse proxies, which if hit would cause the UI to get a failed response.

thanks
yes I was trying it through nginx
I will try it through ssh tunnel next time