Manual import fails

Version: 2.0.0.5344
Mono Version: 5.20.1.34
Running on Ubuntu in Docker

When I do a Manual import, I get an failure: “Unable to load files for manual import. Check logs for more details.”

Now when I do the same, but go down to the directory level where the mkv file is, I can import.
This issue is only since I upraded to the new version 2 days ago. I also had to rebuild my whole database due to an error, so I could have missed a setting somewhere but so far I was not able to find it.
PS I tested just with moving the mkv files a directory up to see if I could import, but this fails with the same error…

Kind regards Gerrit

The log looks like this:
Details
Message
Request Failed. GET /api/manualimport: Sequence contains no matching element

Exception
System.InvalidOperationException: Sequence contains no matching element
at System.Linq.Enumerable.Single[TSource] (System.Collections.Generic.IEnumerable1[T] source, System.Func2[T,TResult] predicate) [0x00070] in <798dd06330af4ca3886d7d2be5573af7>:0
at NzbDrone.Api.ManualImport.ManualImportModule.AddQualityWeight (NzbDrone.Api.ManualImport.ManualImportResource item) [0x00020] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ManualImport\ManualImportModule.cs:35
at System.Linq.Enumerable+SelectListIterator2[TSource,TResult].ToList () [0x0002a] in <798dd06330af4ca3886d7d2be5573af7>:0 at System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable1[T] source) [0x0001f] in <798dd06330af4ca3886d7d2be5573af7>:0
at NzbDrone.Api.ManualImport.ManualImportModule.GetMediaFiles () [0x001c4] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ManualImport\ManualImportModule.cs:28
at NzbDrone.Api.REST.RestModule1[TResource].<set_GetResourceAll>b__32_0 (System.Object options) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\REST\RestModule.cs:111 at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Func2<object, object>,object)
at Nancy.Routing.Route+<>c__DisplayClass4.b__3 (System.Object parameters, System.Threading.CancellationToken context) [0x00049] in <63c44d6f8d7e4f339a987bf9eb94d931>:0

How are the files named?

This is an incompatibility with the source (TV, DVD, Bluray) and the resolution the file says it is, a file with DVD and 720p in the file name would lead to this error as example.

I have tried Some More and found out that it’s not the filename but if there is a sub directory or not. If there is a level deeper sub (e.g. for subtitles) then I get the error if I delete the subdirectory, the import functions.

Br Gerrit