Mac access to NAS drive

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows):6.10.0.104
OS: macOS Big Sur 11.0.1
Debug logs:
Description of issue:
When I go to set a TV shows path it will let me browse to /Volumes/Public/ which is the share on my WD EX4100 but no folders show up. I can browse it from Finder without any issues. I also have PLEX running on the same Mac and it can access the files on the NAS drive.

I can’t even get it to rename files locally. Once I download a file I get this message:

Import failed, path does not exist or is not accessible by Sonarr: /Users/username/Downloads/TV/S.W.A.T.2017.S04E03.720p.WEB.H264-GGWP

I went into security & privacy and set Sonarr with full disk acces.

I just don’t get it. The volume loads on boot and I can browse without any issues with Finder. When I go through the web interface and try and set a directory for a specific series I get to /Volumes/Public but that is it. I am so confused. I feel like I am so close to making this a great solution but I am stuck.

I can also browse the network volume from finder and see all the sub folders.

Ok, I think I figured it out. I ran mono /Applications/Sonar.app/Contents/MacOS/nzbdrone.exe from terminal and now I can access my NAS drive.

This also worked for me. Thanks! (Small typo in your command, …Sonarr.app…)

What sort of nas are you running.
It might be that you nas is more set up for nfs and your mac is setup for smb or the other way around or something like that.
There was a big thing a while ago with mac not playing nicely with some smb and mac had their own one if I’m not mistaken.

I personally side step all of that (on Windows)
I download locally and then use a separate application to move the files into my servers dump folder for handbrake to handle before Emby then renames and puts into folders.