Keeps shutting down, MacOS 12 Monterey

Sonarr version (exact version): 3.0.6.1276
Mono version (if Sonarr is not running on Windows):6.12.0.147
OS: macOS 12 Monterey
Debug logs: https://www.dropbox.com/s/j1mvju40slz92hx/sonarr.debug.txt?dl=0
Description of issue:

Basically, I keep running Sonarr and after a while it will just randomly shut down. I know it might be an issue with MacOS 12 but appears to be no mentions from anyone else, and I doubt I am the only person to be trialling the new OS. Which leads me to think it could be an issue on my end. If anyone can help that would be great.

1 Like

Please read the text for how to properly provide logs that you clearly ignored.

  • Post the full log to hastebin/pastebin/dropbox/google drive or something similar and link it here
  • Do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document

https://wiki.servarr.com/sonarr/troubleshooting#logging-and-log-files

But generally speaking beta OSes are not supported.

If they work, great. If they don’t, well that’s something to explore closer to final release once an RC is out if needed

Have same issue so its not just you

I also have this issue, but by running it via console seem to have discerned (at least in my case) that it is actually a failure on the part of Mono, which crashes. What I don’t know, is why or how to fix it.

Hi I had the same issue and updated Mono to the latest preview release and it appears to have stopped the crashes.

I have downloaded Mono 6.12.0.147 and I still experience the same issue. Running through terminal looks like its having a memory issue. I wonder, if it the preview fixed it for some others too.

So… on my system nothing has been updated, be it mono, OSX, or Sonarr, but it’s magically working. I ran it via console for the umpteenth time and this time it asked for my permission to access the downloads folder. Uptime now at almost 9 hours. It previously wouldn’t go beyond 3 minutes. I can only assume this permissions request was what was pending before, and I"m not sure why it didn’t ask… but that’s the only variable I can see that has changed. Fingers crossed.

BTW… also running mono preview, but that update in itself didn’t fix the problem straight away.

It did get really bad again recently kept crashing not sure if anyone else has still been having issues. I found that by completely uninstalling every part of mono and reinstalling it. It appears to have fixed the issue for now.

Currently on Monterey public beta, Sonarr is also continuously crashing for me (will not stay open for longer than 2 minutes or so). I’m not super technically savvy so I’m not sure where error logs might dump, but can post those once I track them down.

Tried deleting my database file and that helped for a short time, but once everything was up and running again it has resumed frequent crashes.

I know Monterey isn’t officially supported yet, hoping for a fix once it’s released!

Thanks for the suggestions in the thread so far :slightly_smiling_face:

I know its not officially out until next week but they have released the Release Candidate for Monterey and the Sonarr/Mono still crashes through use, sometimes it works straight away other times it will crash out after a few hours/days. So, just a heads up for any of those upgrading to Monterey next week it will be an issue.

1 Like

Yup, I’m on the fully released version of Monterey (12.0.1) and can confirm that the crashing issue still persists.

x-ref https://github.com/Sonarr/Sonarr/issues/4718

@TheLuckiest @loneshade @AndrewGBall @Frizzy @BlueHorizonUK

See if updating the sqlite library fixes it - details, link to the binary, and instructions in the link

Edit: sadly will not work on M1 - so ya’ll are probably SOL until sonarr switches to .net5 (or .net6)

sorry for the false hope guys

1 Like

I’m experiencing crashing as well but its typically within a minute or two of launching Sonarr and will never go longer than three minutes.
Is this your experience as well?

This library update is looking really promising! No crashes so far…will report back if anything changes.

Thank you so much @bakerboy448!

From what I could tell, it was dependent upon whether Sonarr was actively searching/updating the RSS. So it would basically stay alive until that search began and then it would crash partway through.

yup, thats exactly my behavior. it wouldn’t fail on any particular scan, appeared to be randomized during the RSS search.

I’ll give that library update a go, if I can figure it out.

*edit - just noticed the library update won’t work on M1 systems. SOL is now my current status.

Not ideal but can use a launchd script to continually reopen Sonarr til mono workaround is fixed.

  1. Open a text editor and paste the below:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
        <key>RunAtLoad</key>
        <true/>
        <key>KeepAlive</key>
        <true/>
        <key>Label</key>
        <string>Sonarr.restart</string>
        <key>ProgramArguments</key>
        <array>
                <string>/Applications/Sonarr.app/Contents/MacOS/Sonarr</string>
        </array>
</dict>
</plist>
  1. Save file as Sonarr.restart.plist in ~/Library/LaunchAgents/
  2. Open Terminal and run launchctl load ~/Library/LaunchAgents/Sonarr.restart.plist

Has kept it up all day (obviously still crashes)

This patch seems to fix it, however, before it would work for a few days at a time then repeatedly crash. So, I will likely keep this forum updated. As time progresses.