Jobs stuck on Downloading, 100%: Aren't processing further


#1

Sonarr version: 2.0.0.5301
Mono Version: 5.18.0.240
OS: Raspbian Stretch Lite - November 2018
Debug logs: https://pastebin.com/23ayHSBv
Description of issue: I’m running the linuxserver/sonarr docker container, along with separate containers for plex and deluge. Sonarr is able to grab torrents and send them to deluge, but they get stuck at 100% and aren’t processed or moved to the show folder as expected.

Interestingly, running the manual import does parse and process the episodes properly. I can’t seem to find any kind of failures concerning the automatic import in the logs, to my eyes it just seems to not be happening. Other steps I’ve tried include:

  • Changing drone factory interval from 1 to 0
  • Confirming labels match between sonarr and deluge
  • Restarting whole system repeatedly

Any help is appreciated!


#2

In Deluge? as in, it is at 100%, but is still in the downloading state rather than the seeding state? That is a Deluge issue, not a Sonarr issue. If you watch Deluge a lot, you will notice that it goes to 100% while it is still downloading pieces. Most likely there are a couple of pieces that it thought it had, but didn’t actually get flushed to disk, or that are just missing somehow. Easiest thing seems to be to force a recheck of that torrent. This will normally unstick it.

This should be 0 anyway. Drone factory is depreciated and will be removed from future versions.

Hope that helps. :grinning:


#3

Delue was actually showing the torrents as “Completed” for at least 10 minutes while Sonarr itself was stuck on the purple “100%” bar.

Being that it’s rPi and Docker though, I tried redoing my steps from scratch which took all of 45 minutes, and it does seem to work on this new instance. I can’t see anything I did differently, but I’m willing to chalk this up to pebkac :slight_smile:


#4

Ahh. In the Sonarr queue, was the status icon in the left most column yellow by any chance?


closed #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.