Issues opening Sonarr


#1

Sonarr version (exact version): v2.0.0.5301
Mono version (if Sonarr is not running on Windows): 4.42
OS: Fedora
Debug logs: https://www.dropbox.com/sh/vx6g77osc0u2qek/AAC4P5FcXVf7z9Beg4P6kWsna?dl=0
Description of issue:

Hey guys,

I changed Sonarr settings on Fedora to try and get reverse proxy working (changed enable SSL + URL base as per https://github.com/Sonarr/Sonarr/wiki/Reverse-Proxy) and now it seems that Sonarr refuses to start on my server (which is odd in and of itself).

Getting the following:

Redirecting to /bin/systemctl status sonarr.servicesonarr.service - Sonarr DaemonLoaded: loaded (/usr/lib/systemd/system/sonarr.service; enabled; vendor preset: disabled)

Active: failed (Result: exit-code) since Sun 2019-03-10 00:32:28 GMT; 1s agoProcess: 20844 ExecStart=/usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr (code=exited, status=1/FAILURE)Main PID: 20844 (code=exited, status=1/FAILURE)

Mar 10 00:32:26 localhost.localdomain systemd[1]: Started Sonarr Daemon.Mar 10 00:32:27 localhost.localdomain mono[20844]: Press enter to exit…

Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Main process exited, code=exited, status=1/FAILURE

Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Unit entered failed state.Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Failed with result ‘exit-code’.

After uninstalling and reinstalling Sonarr on Fedora and restoring the backups, if I run “/usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr” sonarr starts with the correct settings and database.

Further note: Nginx is loaded on a raspberry pi, so no direct changes apart from the above have been done to the Amahi installation.

Sonarr logs only appear if I run things manually via /usr/bin/mono (which is when I can get it to work)

Any ideas on what I’ve cocked up?

Thanks!


#2

OK,

I’ve scrubbed it fully from my system and intend to start again.

I now get the following error when starting the service :

sonarr.service - Sonarr Daemon

Loaded: loaded (/usr/lib/systemd/system/sonarr.service; disabled; vendor preset: disabled)

Active: failed (Result: exit-code) since Sun 2019-03-10 16:18:11 GMT; 3s ago

Process: 11649 ExecStart=/usr/bin/mono /opt/NzbDrone/NzbDrone.exe -nobrowser -data /opt/NzbDrone (code=exited, status=2)

Main PID: 11649 (code=exited, status=2)

Mar 10 16:18:08 localhost.localdomain mono[11649]: [Info] OwinHostController: http://*:8989/sonarr/

Mar 10 16:18:08 localhost.localdomain mono[11649]: [Info] OwinHostController: http://*:8989/

Mar 10 16:18:08 localhost.localdomain mono[11649]: [Info] OwinHostController: https://*:443/sonarr/

Mar 10 16:18:08 localhost.localdomain mono[11649]: [Info] OwinHostController: https://*:443/

Mar 10 16:18:09 localhost.localdomain mono[11649]: [Info] NancyBootstrapper: Starting Web Server

Mar 10 16:18:09 localhost.localdomain mono[11649]: [Fatal] ConsoleApp: Access denied. This can happen if another instance of Sonarr is already running another application is using the same port (default: 8989) or the user has insufficient permissions

Mar 10 16:18:09 localhost.localdomain mono[11649]: Press enter to exit…

Mar 10 16:18:11 localhost.localdomain systemd[1]: sonarr.service: Main process exited, code=exited, status=2/INVALIDARGUMENT

Mar 10 16:18:11 localhost.localdomain systemd[1]: sonarr.service: Unit entered failed state.

Mar 10 16:18:11 localhost.localdomain systemd[1]: sonarr.service: Failed with result ‘exit-code’.

Any thoughts?

sudo netstat -tulpn | grep :8989 shows nothing in this case, so it looks like it’s permissions?


#3

Interesting thing I’m noting:

If I run the process manually, I get the following:

[Info] OwinHostController: Listening on the following URLs:
[Info] OwinHostController: http://*:8989/

If I run it as a service, I get the following:

Mar 12 17:57:26 localhost.localdomain mono[26469]: [Info] OwinHostController: http://:8989/sonarr/
Mar 12 17:57:26 localhost.localdomain mono[26469]: [Info] OwinHostController: http://
:8989/
Mar 12 17:57:26 localhost.localdomain mono[26469]: [Info] OwinHostController: https://:443/sonarr/
Mar 12 17:57:26 localhost.localdomain mono[26469]: [Info] OwinHostController: https://
:443/


#4

Looks like your BindAddress in the config file was wiped out, it should be * by default, you can find that in Sonarr’s AppData Folder.