InvalidOperationException - Can't Start Sonarr

Sonarr version (exact version): 3.0.3.868
OS: Windows 10 Pro
Debug logs: Debug log link:

UpdateLog link:

Description of issue: Sonarr no longer starts after what looks like an update might have failed to install on 6/8 from the phantom-develop branch.

Sometimes, I’ve noticed that starting the service manually will kickstart it when there are issues, but starting it this way now gives “The Sonarr service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.”

I run it locally on my PC and start it as a service. It’s on port 38081 instead of the default and is not available over the internet. I use a PiVPN to access it if I need remote access. No Sonarr settings were changed (by me) between the day it worked fine and the day it stopped working. As far as I can see, no Windows updates were installed either.

Yeah, looks like the update failed and failed to roll back, grab the latest release from sonarr.tv and re-install.

Not sure how it would have failed to copy that file unless it got blocked by anti-virus.

Can I just swap the config.xml and sonar.db files into a new install and pick up where I left off?

Reinstalling won’t wipe them out (unless you’ve merged the config and bin directories and then you’d be wiping it out every update), but you can copy them to another location if you want to be sure.

Simple enough. I’ll give it a shot when I get home tonight then. Thanks!

Looks like that didn’t quite do the trick. I kept getting the same error after the re-install.

I kept playing around with re-installing and I was able to get it working again by doing the following:

  1. Uninstall and remove the ProgramData folder entirely (after backing up the DB and Config file.
  2. Reinstall app and service
  3. Restart
  4. Replace fresh DB and Config with my backed up version
  5. Restart Sonarr service