Invalid season or episode - full season - all files

Sonarr version: 2.0.0.5344
OS: Linux
Debug logs:
20-11-10 20:21:13.9|Debug|Parser|Parsing string ‘Series.Title.S0601.720p.WEB-DL.DD5.1.H.264-NOGRP.mkv’
20-11-10 20:21:13.9|Debug|Parser|Episode Parsed. Series Title - Season 601
20-11-10 20:21:13.9|Debug|Parser|Language parsed: English
20-11-10 20:21:13.9|Debug|QualityParser|Trying to parse quality for Series.Title.S0601.720p.WEB-DL.DD5.1.H.264-NOGRP.mkv
20-11-10 20:21:13.9|Debug|Parser|Quality parsed: WEBDL-720p v1
20-11-10 20:21:13.9|Debug|Parser|Release Group parsed: NOGRP
20-11-10 20:21:13.9|Debug|VideoFileInfoReader|Getting media info from /path/Series.Title.S06.720p.WEB-DL.DD5.1.H.264-NOGRP[rartv]/Series.Title.S0601.720p.WEB-DL.DD5.1.H.264-NOGRP.mkv
20-11-10 20:21:13.9|Debug|AggregateQuality|Using quality: WEBDL-720p v1
20-11-10 20:21:13.9|Debug|ImportDecisionMaker|File rejected for the following reasons: [Permanent] Invalid season or episode

Description of issue:
The Series.Title is a well known series for which all other episodes have been processed properly. Just this one causes trouble. Quality is set properly and downloaded as part of full season (not sure if it matters).

Tried earlier to put files directly into season folder - but files didn’t get recognized - this is really annoying.

I’m running out of ideas instead of manually renaming files, but not sure what’s the problem with these files and would prefer to find culprit.

Probably “S0601”, try “S06E01”?

Thanks @Thirrian - gave it a go - no juice :frowning:
The culprit is in here:

Recently Watchtower updated qbit as part of linuxserver move from 4.2.5 to 4.3.0 and belief is that it fails because of this.

But also something else is in parallel that even manual import doesn’t go through - trying to import manually - nothing happens not a single log line even in trace mode. Something is odd :frowning:

Seems like github level issues are being pushed back here - so issue raised, but closed.

If anyone has an idea - happy to get some help/thoughts as dunno where the problem is.

UPDATE:
Renaming file didn’t work.
But renamed files thrown into season folder have been discovered and worked. (weird!).
The “E” was missing, but… that naming came from torrent - so maybe parsers would need an update :frowning: