Indexer Setup Timing Out

Sonarr version (exact version): 3.0.5.1144
Mono version (if Sonarr is not running on Windows): 5.20.1.34
OS: Synology DSM 6.2.4-25556
Debug logs: See below
Description of issue:

I am in the process of migrating from a windows based Sonarr server to DSM server. On the windows server everything I can test the indexer and everything works perfectly. I am using the newznab profile. However when I try the same settings on the DSM server, the connection times out. I verified that the settings fields match 1-1 between Windows and DSM. Both Windows and DSM servers are on the same network. Is there a setting I need to change on my NAS server to make this work?

Here’s the log file for the timeout error:

[v3.0.5.1144] System.Net.WebException: The operation has timed out.: 'https://api.nzbplanet.net/api?t=caps&apikey=(removed) —> System.Net.WebException: The operation has timed out.
at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000f8] in :0
at System.Net.HttpWebRequest.GetResponse () [0x00016] in :0
at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x00123] in <838290d41cb7431fbc4fa8070d0b0648>:0
— End of inner exception stack trace —
at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x001e7] in <838290d41cb7431fbc4fa8070d0b0648>:0
at NzbDrone.Common.Http.HttpClient.ExecuteRequest (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookieContainer) [0x00086] in <838290d41cb7431fbc4fa8070d0b0648>:0
at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00008] in <838290d41cb7431fbc4fa8070d0b0648>:0
at NzbDrone.Common.Http.HttpClient.Get (NzbDrone.Common.Http.HttpRequest request) [0x00007] in <838290d41cb7431fbc4fa8070d0b0648>:0
at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider.FetchCapabilities (NzbDrone.Core.Indexers.Newznab.NewznabSettings indexerSettings) [0x000a1] in :0
at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider+<>c__DisplayClass4_0.b__0 () [0x00000] in :0
at NzbDrone.Common.Cache.Cached1[T].Get (System.String key, System.Func1[TResult] function, System.Nullable1[T] lifeTime) [0x000b1] in <838290d41cb7431fbc4fa8070d0b0648>:0 at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider.GetCapabilities (NzbDrone.Core.Indexers.Newznab.NewznabSettings indexerSettings) [0x00046] in <eea51fec6dbe458b873ba10bf3c0a405>:0 at NzbDrone.Core.Indexers.Newznab.Newznab.get_PageSize () [0x0000c] in <eea51fec6dbe458b873ba10bf3c0a405>:0 at NzbDrone.Core.Indexers.Newznab.Newznab.GetRequestGenerator () [0x0000b] in <eea51fec6dbe458b873ba10bf3c0a405>:0 at NzbDrone.Core.Indexers.HttpIndexerBase1[TSettings].TestConnection () [0x00007] in :0

21-4-3 10:12:49.9|Warn|SonarrErrorPipeline|Invalid request Validation failed:
– : Unable to connect to indexer, check the log for more details

BUMP. Is anyone able to help with this?

Other than 3.0.5 being out of date…

Networking issues are almost always local problems caused by a vpn, proxy server, ipv6, or DNS issues

Hi guys,
I have exactly the same problem as dw03 describes above! Also migrating from a Windows10 machine to my new DS418.
It seems clear to me it is a Mono problem. On the SynoCommunity i found that Sonarr V3 worked with the Mono version 5.8. And after reinstalling it did, for some time… Since 3 days however again Sonarr cannot contact NZBgeek for indexing.
I’m weary to reinstall both Mono 5.20 and Sonarr again.
Anybody any idea how to solve this problem?
NB Radarr runs perfectly, both with Mono 5.8 and 5.20

Glad to hear I’m not the only one facing this issue. I will try 5.8 though it sounds like it’s hit or miss. Radarr is having the same issue for me with the timeouts. I also use Emby for media management and it is failing to connect to it’s license server and timing out. I reached out to Synology support and turned off firewall, Denial of service and all the security settings they suggested to no avail.

So 5.8 works for me so far fingers crossed. I am still having timeout issues on Radarr though. GandulfM, are you using the package from SynoCommunity? This does not appear to have a mono dependency and am wondering if it bundles Mono 5.20 automatically with it. I am using 20210311-15

I have now Sonarr Version 3.0.6.1196
Mono Version 5.8.0.108
and yes, all from SynoCommunity
When you install Mono 5.8 and after that Sonarr, it doesn’t install 5.20. I do get a warning though to upgrade to 5.20, but didn’t do so, it also didn’t work.
I’m quite sure it is the Sonarr package from SynoCommunity that has an error and therefor doesn’t cooperate with Mono. Radarr works fine:
Radarr Version 3.0.2.4552
Package Version aarch64-6.1_20210311-15 by Team Radarr
Oh, here you find the architecture of your Synology: https://github.com/SynoCommunity/spksrc/wiki/Architecture-per-Synology-model
then find the Mono version here: https://synocommunity.com/package/mono
and for Sonarr: https://github.com/Safihre/spksrc/releases/tag/sonarr-v3-build
WARNING: A PROVISIONAL V3 package and installation instructions are provided by SynoCommunity at: https://github.com/SynoCommunity/spksrc/pull/3803.
So apparently this Sonarr version still is in test phase…maybe we need to wait for next version to have the Mono problem solved.

Thanks GandulfM. I agree with you this is a mono issue. According to this redditor it has to do with the way mono handles TLS encryption: https://www.reddit.com/r/synology/comments/ezslod/update_the_version_of_mono_that_sonarr_radarr_use/

I am using the same version of Radarr as you but am having the same indexer timeout issues. When I uninstalled Mono it said only Sonarr had a dependency. Do you know if Radarr gets installed with its own version of Mono? Is there a way to force it to use 5.8?

Radarr on Synology should not be still on mono; .netcore build is available update.

As for sonarr, 5.20 is the preferred.

Mono on Synology is also frankly a shitshow. mono is busted on aarch64

I’m new to DSM but if I go the docker route, would you expect these types of issues to go away? It seems like it’s more work to set up, but if it gets me feature parity with the windows apps then I’ll just bite the bullet.

I tried to install Docker, but my DS418 doesn’t accept it
And to force Sonarr to use Mono 5.8 is just to install Mono first, then Sonarr accepts it, but DSM warns you to update mono.
BUT… my Raspberry Pi now runs Sonarr without a problem. I just need to transfer the files to my DS418. Shame on you Synology!
3rd edit :slight_smile: it seems all to come right with DSM 7.0, end of this year.

Hi GandulfM, I can’t tell if you’re being facetious…are you saying that Synology is aware of the issue and will be fixing this in DSM 7.0? Or is this just wishful thinking :smiley:?

Hi dw03, it is what I understand from comments on fora… it’s what “experts” hope that might happen lol. They hope on a version from Sonarr that doesn’t need Mono to run, like Radarr.
Anyway, my believe is that the Synology NAS’es having an ARM V8 architecture have problems with the latest versions of Sonarr.
My DS418 has this chipset. it’s called rtd1296 (armv8) architecture.
There are versions of Sonarr specially designed for this architecture. My post April 11 tells you how to find the architecture of your NAS and then where to find the proper version of Sonarr. I found this info on in other posts.
So I uninstalled Mono and Sonarr, then manually installed Mono 5.8 first (just to be sure), then the proper version of Sonarr.
Sonarr is running now, though I get warnings to upgrade Mono and Sonarr.
I don’t know what the architecture of your NAS is, but check this out.
Good luck!