Import failed (local path exists but is not accessible)

Sonarr version (exact version): 2.0.0.5344
OS: Windows 10 (19042.630)
Debug logs: https://pastebin.com/2b4LqAZJ
Description of issue:
Recently, Sonarr has had a problem importing files from qBittorrent. Sonarr and qBit are both running on the same machine, but once the download is complete, Sonarr is unable to import it.

Manually importing it just brings up “No video files were found in the selected folder.”

Here’s a recent example of what the logs say when trying to import a download:
Import failed, path does not exist or is not accessible by Sonarr: C:\Users\Brian\Downloads\The.Mandalorian.S01E08.1080p.WEBRiP.x264-PETRiFiED[rartv]

However, the path does exist and there are files inside. I’ve also confirmed that the Downloads folder permissions include read and write permission. I’ve tried to diagnose it but am having no luck. I even tried wiping Sonarr from my server, but a fresh install had the same issue.

Which version of qbittorrent?

Ah, it’s definitely whatever the most recent version of qBit is. Guessing I should downgrade it and see if that fixes the problem?

(Or if anyone knows a better windows bt client, I’m open to suggestions!)