How To Stop Monitoring? (Synology, FileBot ?)

Sonarr version (exact version): 3.0.3.688
Mono version (if Sonarr is not running on Windows):5.20.1.34
OS: Doccker
Description of issue: So my stack is not simple…

Sonarr
Jackett
Synology
FileBot
Emby / Kodi / Plex

At the moment, sonar monitors, and sends the download to Synology, it downloads the file as expected. Every 2 hours, a scheduled process picks up the file and places into the correct location, with correct name etc.

Sonnar sees it as still downloading on synology until I manually press clean to remove it from the completed list.

Sonarr never sees it on disk and gets late notifications of the download being complete, as I manually clean the Synology complete list.

What this means, is that episodes are downloading over and over again.

I have set “Ignore Deleted Episodes”, however this doesn’t seem to do anything… Manually telling it to stop monitoring is just pure crazy, makes the point of having an automated setup pointless.

Even if I was to allow sonarr to see where the files are moved to, becuase filebot is taking care of the renaming, I assume it will just continue.

How can I stop this craziness?

I have just noticed “Upgrades Allowed”, so I have turned this off as well, I will try and feedback either way.

It’d then know the file was downloaded at least, right now it’s going to treat everything as missing.

You need to turn off completed download handling to have Sonarr automatically remove completed downloads from queue, which will also keep it from upgrading to other releases.

That only applies if it saw a file imported then it was deleted. If it’s never there it’s not deleted.

Definitely, but so is not allowing Sonarr to see the imported files so it can track what is actually there.

@markus101, Thanks for coming back, I wasn’t alerted by email.

When you say, turn off completed download handling, do you mean stop FileBot from doing it, or can I ask Sonarr to stop wanting to do that?

Cheers

Completed Download Handing is in Sonarr, turning it off will stop Sonarr from trying to import, but unless Sonarr sees the imported files it won’t know you have the files; ideally it does the importing and tracks the files you have. Currently your setup is limiting Sonarr’s ability to function to it’s full potential.

@markus101 , sorry where do I turn this off?

Settings: Download Clients

why dont you let sonarr handle everything up to importing it? perhaps explain why letting sonarr import it doesnt work for you?

you could then add your filebot processing into a post import processing script to do whatever else youre doing to it?