How to add "TV" library in "video" folder

If you just use the right folder mapping then it will work fine.

Seems correct by what I’ve posted doesn’t it?

Only thing I took another guess at that might be wrong is for the sabnzbd download client. for the ROOT PATH, mine looks like this:
\SERVER\downloads\complete\

It works through explorer but not sure if thats what it’s looking for
the LOCAL path where I can browse shows files in the folder so I know that works.

Again, given that the error shows /volume1/downloads/..., you mapping /downloads to /downloads obviously isn’t right.

Do you have a better answer? I’m here for help, I’ve followed the guides, just telling me “it’s wrong” without providing anything else doesn’t really solve the problem. I’ve spent hours trying different ways with no definitive answer. No one’s fault, but for novice user that used to just install it like any other app, this is beyond frustrating. I mean everything else works except simply moving from downloads that are completed to the proper library. It doesn’t matter where that library is as I’ve tried others. The download client within Sonarr works and sonarr sees the files as a manual import works, so I’m having trouble understanding exacty what you’re suggesting. Again, appreciate you taking a look, I know no one is paying you for this!

As in it should be /volume1/downloads

It should not be this.
In fact, his downloads folder should go into the /data share.
That way instant moves and hardlinking will work.

Read:

You already posted the same link, you were ignored for a reason. Read the actual thread.

Ignoring the guide is what made his setup a mess.
Synology lied that you can’t make other share available for DLNA.

So just copying all his old content from /VIDEO or /TV or whatever into the /data/media would make Sonarr be able to see everything.

And adding /media as DLNA folder, would make his TV see the media as well.

Meanwhile I’m happily using Sonar v4 outside of Docker with zero issues which I avoided at first because someone claimed it didn’t work. They were wrong.

There are some permission issues with either setup, that much I’m sure of, I think I just got lucky as the system users created can’t be deleted easily and after a few install attempts, it finally worked with the old user name/ system user names.

The guides are great, but not perfect. I moved files, tested scenarios and between bad info and it not performing properly, I moved on. I do suspect there’s an issue with Docker on that particular system as after a few runs I couldn’t even login to Sonarr, this was consistent. Logs didn’t seem to offer much at all as to why anything was happening. The DLNA answer sounded wrong when I heard it but again, without the guidance, what was I going to do? Even now, how is that done exactly? I ended up moving the folders into the DLNA folder and now everything does what I want the way I want and I hope I never have to deal with this again.

I’m still confused with Docker in general, i thought the idea was portability and compatibility, then why can I just take someone else’s Sonar container and drop it mine with a few adjustments? I know, “reasons” lol.

The goal should be to help everyone get Sonarr working, not I lectures and “I told you so” after the fact don’t you think?

1 Like