Help with "Import failed path does not exist..."

Sonarr version (exact version): 2.0.0.5344 in docker
Download client: Download station native
OS: DSM 6.2.3 Synology ds720+

Description of issue: Hello all, i’m having hard times trying to troubleshoot this error.

settings in docker for sonarr are:
/volume1/PlexMedia/ : /data
/volume1/docker/sonarr: /config
ownership on these 2 folders is on my admin account
added puid and pgid codes for my admin account.

Mapped remote path in this way:
host: 10.10.10.137
Remote path: /volume1/PlexMedia/Film&Serie/downloads/
Local path: /data/ (tried also with /data/Film&Serie/downloads/)

still getting error: [Error] DownloadedEpisodesImportService: Import failed, path does not exist or is not accessible by Sonarr: /volume1/PlexMedia/Film&Serie/downloads/
Don’t know what to try anymore.
Can anyone please advise?
Thanks,
Regards

First thing to try, but I kind of already know the answer: start (no need to complete) a manual import in sonarr, and browse to /volume1/PlexMedia/Film&Serie/downloads/.

If you can’t find this path (doesn’t surprise me): start a manual import in sonarr, and browse to /data/Film&Serie/downloads/
Can you reach this location?
Can you browse further into the downloads folder, to an actual download?
Can you import the download?

If yes to all of the above: permissions should be ok, good!
Make a note of the path you had to browse. If it is in any way different, that’s important to know later. If not, I am assuming it’s /data/Film&Serie/downloads/ in the steps below.

Go to Settings > Download Clients
Open the details of your download client, and note the Host setting.
Close the details.

Add a remote path mapping.
Host: what you copied earlier from your download client settings.
Remote Path: /volume1/PlexMedia/Film&Serie/downloads/
Local Path: /data/Film&Serie/downloads/
It’s possible the trailing / is not required, I don’t recall. I haven’t used remote path mappings for ages.

Thanks for your reply.
At the end i solved it, i moved everything to /volume1/Plexmedia/… [subfolders with movies and tv shows] deleting the unecessary “Film&Serie” folder and then it magically worked.
Don’t ask me why but i think Sonarr didn’t like the path location. Maybe the “&” character was creating the issue.