"Failed to add task from data" invalid data

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows): 5.20.1.34

OS: Synology
Debug logs:
Request Failed. POST /api/release: Failed to add task from data The Voice S20E05 720p HEVC x265-MeGusta.torrent. Reason: Invalid parameter

NzbDrone.Core.Download.Clients.DownloadClientException: Failed to add task from data The Voice S20E05 720p HEVC x265-MeGusta.torrent. Reason: Invalid parameter
at NzbDrone.Core.Download.Clients.DownloadStation.Proxies.DiskStationProxyBase.ProcessRequest[T] (NzbDrone.Common.Http.HttpRequestBuilder requestBuilder, System.String operation, NzbDrone.Core.Download.Clients.DownloadStation.DiskStationApi api, NzbDrone.Core.Download.Clients.DownloadStation.DownloadStationSettings settings) [0x000d1] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Core.Download.Clients.DownloadStation.Proxies.DiskStationProxyBase.ProcessRequest[T] (NzbDrone.Common.Http.HttpRequestBuilder requestBuilder, System.String operation, NzbDrone.Core.Download.Clients.DownloadStation.DownloadStationSettings settings) [0x00000] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Core.Download.Clients.DownloadStation.Proxies.DownloadStationTaskProxy.AddTaskFromData (System.Byte[] data, System.String filename, System.String downloadDirectory, NzbDrone.Core.Download.Clients.DownloadStation.DownloadStationSettings settings) [0x00045] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Core.Download.Clients.DownloadStation.TorrentDownloadStation.AddFromTorrentFile (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String hash, System.String filename, System.Byte[] fileContent) [0x00039] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Core.Download.TorrentClientBase1[TSettings].DownloadFromWebUrl (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode, System.String torrentUrl) [0x00208] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0 at NzbDrone.Core.Download.TorrentClientBase1[TSettings].Download (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00148] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Core.Download.DownloadService.DownloadReport (NzbDrone.Core.Parser.Model.RemoteEpisode remoteEpisode) [0x00191] in <4d3cc4e5f7ed4ed2814d83bdaf94809e>:0
at NzbDrone.Api.Indexers.ReleaseModule.DownloadRelease (NzbDrone.Api.Indexers.ReleaseResource release) [0x0002d] in <26843969f47a41d8b3373212a52c9c64>:0
at NzbDrone.Api.Indexers.ReleaseModule.<.ctor>b__7_0 (System.Object x) [0x00007] in <26843969f47a41d8b3373212a52c9c64>:0
at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,System.Func`2<object, object>,object)
at Nancy.Routing.Route+<>c__DisplayClass4.b__3 (System.Object parameters, System.Threading.CancellationToken context) [0x00049] in <63c44d6f8d7e4f339a987bf9eb94d931>:0

Description of issue:
I am trying to download via Jacket. Just stopped working last night, with no changes applied.

Tried permissions, restarting, rebuilding Jacket and DownloadStation…

I am getting the same errors
setup

  • Synology NAS
  • Download Station
  • Sonarr 3.0.5.1144

restarted both Sonarr and download station no difference.
popped a nzb into diskstation watch directory and was able to download

i am having the same problem
Sonology NAS
Download Station
Sonarr 2.0.0.5344

my download station just updated and i started to experience this problem so i think its the main cause.

but i go to my download client and click test and its testing successfully, and when i add the torrent to download station it starts with out issue.

so i am stuck now, not sure what i need to check / do to further analyze this issue

ok so after checking for a while, it indeed seems to be an issue with the last update of download station, i uninstalled and manually installed the previous version with the below link and its working for me now.

https://global.download.synology.com/download/Package/spk/DownloadStation/3.8.15-3563/DownloadStation-x86_64-3.8.15-3563.spk?model=DS918%2B&bays=4&dsm_version=6.2.4&build_number=25556&_gl=1avjozk_gaMTIzMjY3NjY0MC4xNjE1OTk2NTQx_ga_9Q8XT3X20D*MTYxNjAwMjQwMC4yLjEuMTYxNjAwMjQ3OS40Mg…&_ga=2.183240674.598799366.1615996541-1232676640.1615996541

TY, I will try this right now

That fixed it. Rockstar!! Now, how do we submit this to Synology?

How will that go? Dear Synology, please fix download station so I can continue to pirate tv shows? :smirk::wink:

I think, as usual when a new version of download station changes something in the api, someone with a synology needs to do some digging to see what changed and propose and test a code change in sonarr to handle the new download station.

Indeed that seems to fix it for now.

Anybody knows if this will be fixed in an update sooner or later?

Known issue… Synology pushed an update that broke the download client and has not updated their API doc in 7 years.

use an actual download client