Deluge - Authentication Failed

I can’t connect Deluge to Sonarr.
It says that the Authentication failed, but I’m sure that the password is correct.
My host is localhost:8112.

I followed the instructions on, but it doesn’t work for me.

Please help!


I think the port may not be correct? I’m not using deluge myself, but check here:

I tried with different ports: 58846 and 8112 are not working, but it should be 8112 anyway.

There’s something wrong with the password, or maybe in my auth file.
But I really don’t know how to fix it.
What can I do?

Yeah 8112 is the correct port.

Are you using a complex password (with symbols in it)?

Try changing your password/removing it to see if that works.

No I was not using a complex password. And now my password is blank. So I don’t need to enter a password when I login into Deluge.

But it’s still not working.
I managed to connect Deluge with the TorrentBlackHole option. And it looks like it works not that bad. What are the pros and cons of connecting Deluge in this way?

Sonarr won’t be able to remove torrents after they finish seeding with the black hole option.

Did you set a separate password in the http plugin for deluge (not sire if there is separate one for that).

So…I think that the password is the same, but anyway, in my auth file this is the only line that I see:

localclient:[a lot of numbers and letters]:10

And when I have to login to Deluge on my browser (going to http://localhost:8112), it asks me for the password, I leave it blank and I press ok. Done. I’m in.

What should I do?

(My Daemon port is 58846 by the way. Just so you know. Even if I don’t know whether this is helpful to fix this problem or not.)

Is authentication enabled in Deluge, with a blank password? I could see that causing issues (Sonarr wouldn’t send a blank password, but Deluge would expect it to be sent but blank).

I enabled the authentication in Deluge with a password (on the browser).
I noticed that the auth file didn’t change. There is the same line.

It’s still not working.
What can I try next?
Thank you so much for the help.

(Oh, and what am I supposed to put in the “URL base”?)

That seems a bit odd, where exactly are you setting it?

Nothing in URL Base unless you’re using a seedbox.

[quote=“markus101, post:10, topic:4568”]
That seems a bit odd, where exactly are you setting it?
[/quote]I’m setting it on the Interface section in Deluge on google Chrome.

I checked the ports on the router, and they should be fine.
But I still can’t connect Deluge to Sonarr.

Any other things that I could try?

Which version of Deluge are you using?

I’m using Deluge 1.3.11 (Web UI).

Are you able to set the password directly in the Deluge UI (not WebUI)?

Also try restarting Deluge after changing it, I recall having to do that when I was testing it before, but its been a while.

Wel…I really don’t know how, but now Deluge is connected. Yesterday I tried again, after a week, and it worked!

Problem is that now the files downloaded are not being removed after they’ve been moved to my tvshows folder.
But I guess there is another topic for this problem, anyone knows which one I should read?


If the download is still seeding it won’t be until its stopped/paused (forget which Deluge uses). Make sure “Remove Completed Downloads is enabled”.

Is this an option in Deluge or in Sonarr?
When a file is downloaded, it goes to “Queue” but it stays in the torrents folder. And sometimes is also copied in the TvShows folder, other times is not.
Thank you for the help!

Thats an option in Sonarr (disabled by default).

Sonarr will copy or hardlink (depending on your Sonarr settings) a seeding torrent that it can process (correct category and Sonarr knows about the series). If things aren’t being processed debug logs will tell you why.

Is this the option in the “Download client” page (in the settings). Cause I think that it is already enabled.