Connection lost error


#1

Sonarr version (exact version): 3.0.1.490
Mono version (if Sonarr is not running on Windows): 5.20.1.19
OS: Ubuntu 18.04.2
Description of issue: Sonarr will randomly lose its connection.

Looking for a way to restart “connection” via terminal


#2

Upgrade mono 4.6 should be the absolute minimum, but 5.20 is out currently.


#3

Sorry I am already using the latest version. I have updated the ticket


#4

You were already using 5.20?
Enabling trace logs and capturing the standard error and output and error to a file will give you the most information why it’s crashing. A common cause of crashing is an old libmediainfo installed. Make sure you’ve installed the latest from their repo, as the latest version in the Ubuntu repo is probably quite old.


#5

Will this give me a log immediately or will I have to wait until it happens again? This can go days until happening again, which is why I am looking for a quick restart option if possible.

There was an update for libmediainfo the version I found was 19.04-1


#6

To see why it’s crashing the log won’t be useful until it crashes.

You should be able to start the system.d service for Sonarr (not sure the command offhand).


#7

I kept the Trace/Debug running and the connection lost again yesterday. There are quite a few Trace and Debug logs. Which one do you need?


#8

The latest file is the one without any numbers, which should be the relevant one if it crashed.


#9

Trace
Debug


#10

Looks like it might be https://github.com/Sonarr/Sonarr/issues/3096 an old version of mono (maybe 5.12?) may help.


#11

First post 8 days ago says: 3.0.1.490
Trace log of yesterday says: [v3.0.1.467]

So what is it?

Anyway, update to 3.0.1.497


#12

I stay pretty up to date with your updates:

So I am going to reinstall mono-devel to the latest version?