Completed Torrents in qBittorrent No Longer Being Removed

I haven’t marked it as solved and I can see it on the list.

1 Like

I’m having the exact same issue. Sonarr V3 (3.0.3.765) and qBittorrent 4.2.3 on unRAID. Radarr seems to be working fine.

Was working 3ish days ago then suddenly not. There may have been an update in that interval.

Edit: Sorry, radarr having the same issue. Not working.

2 Likes

Same issue here.

Sonarr 3.0.3.770
qBittorrent 4.2.3
*OS: Windows 10

Once downloads hit the seed time requirement they mark as finished but are not removed.

1 Like

+1

Same issue here.

Sonarr 3.0.3.770
qBittorrent 4.2.3
*OS: Windows 10

Once downloads hit the seed time requirement they mark as finished but are not removed.

Just started happening the past few days.

Same issue here but with uTorrent.

Sonarr 3.0.3.770
uTorrent 3.5.5
*OS: Windows 10 Pro

Torrent used to reach Finished state after seed time elapsed then was deleted by Sonarr but now reaches finish state but doesn’t get deleted. This started about 4 days ago. Logs are the same as above. I also use Radarr which uses the same torrent folder and service user account but doesn’t have this issue.

Same issue here but with Deluge

Sonarr 3.0.3.770
Deluge 2.0.3-2-201906121747-ubuntu18.04.1
OS: Linux 4.19.97-v7l+

Sonarr & Deluge in Docker

Same here

Docker 3.0.3.770
Transmission & SABnzbd
Occurring on both sonarr and radarr. I’m actually noticing this started back in March for me. The episode is sent to download client, but never gets grabbed from /downloads/completed and imported.

Ubuntu 19.10
Sonarr 3.0.3.770
Deluge @ Seedbox

Used to be able to delete torrents from queue, whether they reached ratio settings or not. Now can’t remove them from Sonarr queue list unless I delete them from Deluge first.

I always deselect “Remove From Download Client” to keep torrent active but clean up my queue list and it always re-propagates.

Github issue here: https://github.com/Sonarr/Sonarr/issues/3693
Please don’t all go there just to say “I have the same issue”. If you want you can subscribe to that github item and get updates that way.
I’m just linking it here so you can see the devs are aware and looking into a solution…

1 Like

The github issue is marked as resolved but after 3 sonarr updates since I still have the issue. Is this resolved for others?

Just tested; the issue is still there.

Latest linuxserver v2 sonarr docker container.

Yeah, I’m still having the issue. I even did an entire new system build yesterday (not to try and resolve this issue but because I wanted to migrate to a new environment) and still having the issue.

New version stats:
Sonarr version (exact version) : 3.0.3.774
Mono version (if Sonarr is not running on Windows) : 6.8.0.105
OS : Ubuntu 20.04 LTS

Also, a few people have posted the same on the github issue.

Issue remains as of now.

3.0.3.777

I’ve written a little script that runs in cron every 10 minutes. It retrieves a list of torrents with the specific sonarr tag and goes through that list to determine any that have completed and deletes the torrent and their files. I’ve configured it to only delete if the download finished more than an hour earlier as well as hit the “completed” status. This gives Sonarr plenty of time to detect the completed download and put all the files in the correct location - couldn’t have been bothered trying to work out how to get that information out of Sonarr (even if it is possible, I probably couldn’t work out how myself). Besides, I expect it’ll only be a short term solution until a proper fix is released so this will just keep things tidy until then.

Happy to share my script if anyone wants it. It’s done in PHP and I’m a complete novice so don’t laugh at it, but it at least works. :slight_smile:

This is written for the qBittorrent v2 API. Can’t help with any other client, sorry.

Scrap that, I worked out how to get that info out of Sonarr - didn’t realise it had an API until today. Will possibly work on that tomorrow because I couldn’t be bothered now. Again, it’s just a temporary measure but thought it might be useful to others.

I’m seeing the same issue for a few weeks now. I’ve just set logging to debug and found the following line in the debug logs but then nothing seems to happen as a result of sonarr being informed from qbitorrent that the download has completed.

20-4-28 09:52:58.5|Debug|TrackedDownloadService|Tracking 'qbittorrent:American.Dad.S16E03.720p.HDTV.x264-AVS[rarbg]': ClientState=Completed SonarrStage=Imported Episode='American Dad - S16E03 HDTV-720p v1' OutputPath=C:\downloads\American.Dad.S16E03.720p.HDTV.x264-AVS[rarbg].

Sonarr 3.0.3.777
qbitorrent 4.2.5

Sonarr 3.0.3.778
qbittorrent 4.2.5

Had to clear the blacklist and searched for completed downloads manually and “re-added” the same completed torrent. Sonarr seems to import the file now and also removes completed torrent from qBittorrent, however the Activity Queue seems to “hang” after a little while (if you try to sort any of the columns, nothing sorts).

This appears to be resolved now in the latest update (3.0.3.780). Just tested and confirmed working as expected.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.