Certificate validation for https://skyhook.sonarr.tv/v1/tvdb/shows/en/76177 failed. RemoteCertificateChainErrors

I understand this is a known issue (Synoloy NAS) Mono problem.

The posts I saw said they fixed it by logging in and running “a command”, would have been nice to get more info or even some instructions, but I didn’t see any.

I know zero about linux so is Sonarr dead for me?

Didn’t see any?
Where did you look…?

It’s in the install instructions, dozens of posts on this forum, the FAQ, and SynoCommunity’s GitHub issues.


I did a quick search, but didn’t see this particular result. I’ll give this a try and thank you.

Ran the instructions using Putty, said “successful” , 10 mins later I checked sonar, it doesn’t search and gave this error.

I did install a new router and checked the port forwarding, so adding 5000-5001,6690 for the IP address of the NAS after the Mono thing gave me back my search and it now seems to be working OK again.

BTW, I’m running docker, so does the MONO procedure still apply? Thinking maybe it was the ports all along but again, I know next to nothing on this.

A new router without port forwarding setup wouldn’t cause TLS issues, but if it’s working now, great, maybe started working after a restart of the service around the time the port forwarding was done?

I updated the mono as instructed ( thank you for even having that), waited a few minutes, wasn’t working yet, then updated port forwarding and seemed like it worked immediately after. Might have been just a timing thing I suppose. Just glad it’s up again. Thanks for all the great work and support, family hardly watches commercials anymore.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.