Certain torrents not being moved after download in qbittorrent

Sonarr version (exact version): 3.0.6.1196
Mono version (if Sonarr is not running on Windows): 6.12.0.122
OS: Ubuntu Server 18.04
Debug logs: https://pastebin.ubuntu.com/p/9WKXgzzvX3/
Description of issue:

TL;DR Occasionally a torrent successfully is sent to qbittorrent and downloads, but Sonarr appears to lose sight of the torrent download and isn’t able to properly move or hardlink once it’s done downloading.

So, some torrents I download from sonarr -> qbittorrent don’t actually get moved to the appropriate series folder after completing the download. The download always completes and I see it in the default qbittorrent download directory (/opt/plexmedia)… But it never moves to the appropriate series directory /opt/plexmedia/series/{series name}. So, no hardlink or anything. After that, I just have to move it to the appropriate series folder manually but it’s getting annoying doing it on a lot of episodes. I notice when this happens, I check the activity right after starting the sonarr search, and it says queue is empty even though it’s already downloading in qbittorrent. Looking at qbittorrent when it’s downloading, the category is as expected (tv-sonarr). Also, in the activity history in Sonarr, it has the “Grabbed from Nyaa and sent to qbittorrent” but doesn’t have the “Episode downloaded successfully and picked up from download client.” like a normal download would have. This isn’t always an issue, as it only happens some specific torrents… Many downloads successfully hardlink to the right series folder. It’s not a permissions issue as everything has full permissions in these directories on linux. Plus, it only happens to a percentage of my download attempts…

For example, in the logs, I download "[SubsPlease] Fumetsu no Anata e - 01 (1080p) [1D65E30D].mkv " and it successfully downloads, then hardlink imports to the Fumetsu no Anata series folder. But then I try to download “[Erai-raws] Nomad - Megalo Box 2 - 02 [1080p][Multiple Subtitle].mkv” it successfully sends it to qbittorrent and downloads, but it feels like it completely loses track of the file after that. It never hardlinks or moves the file into the series folder. It’s not in the logs, but same thing happens on Episode 1. After that, I tried the 3rd episode of Megalo Box "[Erai-raws] Nomad - Megalo Box 2 - 03 [1080p][Multiple Subtitle].mkv"and it works fine. Downloaded, and hardlink imported to the Megalobox series folder. I deleted the 3rd episode again to test, and it works fine. I then deleted the 1st/2nd ep from my files and tried again, and they both have the issue as before. It’s not just for this series either, it happens occasionally in other series I download.

please provide more useful, less spammy logs
https://wiki.servarr.com/Sonarr_Troubleshooting#Logging_and_Log_Files

Weirdly enough, I restarted the sonarr service, and everything processes as expected? I suppose I’ll mark this solved for now.