Can't update to v3 anymore

Sonarr version (exact version): 2.0.0.5338
Mono version (if Sonarr is not running on Windows): 5.10.1.57 & 6.8.0.105
OS: FreeBSD (jail 11.3)
Debug logs:
Mono 5 trace https://pastebin.com/0fMN4NRq
Mono 5 debug https://pastebin.com/GnXq3KKH
Mono 6 trace https://pastebin.com/i9v6HwnR
Mono 6 debug https://pastebin.com/4FGHAG4K

Description of issue:
I recently upgraded my Sonarr to v3 inside my FreeBSD (freenas) jail which was running mono 5.10
I then upgraded to mono 6 for some reason both radarr and sonarr got wiped and I had to reinstall. Since then I’ve not been able to upgrade sonarr to v3 - eveytime I enter phantom-develop into the branch, I only see updates from master. I also built a new jail running mono 5.10 again and still the same things happens. Any ideas why it’s not showing me the phantom builds?

We’ve never supported upgrading from v2 from v3 in Sonarr. You need to install it manually. There are no v2 builds of phantom-develop to install.

1 Like

Thanks for the response. That’s strange since I definitely updated that way previously before trying to update mono and it was all successful and running v3 with the the new UI. The only reason I tried to upgrade mono after that was so I could also update Radarr.

Is there a way to manually install v3 for mono inside a freenas jail then?

Edit: Have installed sonarr v3 via pkg install sonarr-devel
Wasn’t aware the package existed!

Hi, I’m trying to figure out how to install V3 as well. I can get V2 up and running no problem, but I don’t see a definitive guide for v3 on FreeNAS.

I see the sonarr-devel package. How do I go about using that?

I was thinking it would be as simple as setting up a new jail and then running this command from inside the jail. I tried this, but I was unable to reach the GUI. Is there something that I’m missing here?

Thanks.

Hello.

Not sure if you’ve already got this working but you need to enable and start the Sonarr service after installing.

Assuming you’ve got the package installed successfully, run:

sysrc sonarr_enable=“YES”
service start sonarr