Can't add indexer NZBGeek, Input String not in correct format


#1

I’m looking for some help to solve my issue trying to get NZBGeek added as an indexer. I’ve also got this posted at NZBGeek and working through it as well. I have the latest .NET version installed 4.7.2 but still unable to get the indexer added. I have CouchPotato, SABnzbd, and SickBeard working without issue, but unable to get NZBGeek added. This is my 3rd complete reinstall of OS and all software and still can’t get the indexer installed. Any help or direction is appreciated.

Gigabyte B450 Aorus M
Ryzen 2400G
16 gig Corsair Vengeance
OCZ 150 SSD
4 TB WD HDD
550W PSU

Sonarr version 2.0.0.5252:
Windows 10 Home:
“Request Failed. POST /api/indexer/test: Input string was not in a correct format.” This is a new install and setup.

Log info:
Exception

System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at System.Convert.ToInt32(String value)
at NzbDrone.Api.ClientSchema.SchemaBuilder.<>c.<GetValueConverter>b__8_8(String s) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ClientSchema\SchemaBuilder.​cs:line 189
at System.Linq.Enumerable.WhereSelectArrayIterator2.MoveNext() at System.Linq.Enumerable.Any[TSource](IEnumerable1 source)
at NzbDrone.Core.Indexers.Newznab.NewznabSettingsValidator.<>c.<.ctor>b__3_0(NewznabSettings newznab) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Indexers\Newznab\NewznabSe​ttings.cs:line 42
at FluentValidation.AbstractValidator1.&lt;&gt;c__DisplayClass19_0.&lt;Custom&gt;b__0(T x) in C:\projects\FluentValidation\src\FluentValidation\AbstractValidator.cs:line 187 at FluentValidation.Internal.DelegateValidator1.<>c__DisplayClass10_0.<.ctor>b__0(T x, ValidationContext1 ctx) in C:\projects\FluentValidation\src\FluentValidation\Internal\DelegateValidator.cs:​line 58 at FluentValidation.Internal.DelegateValidator1.Validate(ValidationContext1 context) in C:\projects\FluentValidation\src\FluentValidation\Internal\DelegateValidator.cs:​line 82 at FluentValidation.Internal.DelegateValidator1.Validate(ValidationContext context) in C:\projects\FluentValidation\src\FluentValidation\Internal\DelegateValidator.cs:​line 107
at FluentValidation.AbstractValidator1.&lt;&gt;c__DisplayClass12_0.&lt;Validate&gt;b__0(IValidationRule x) in C:\projects\FluentValidation\src\FluentValidation\AbstractValidator.cs:line 114 at System.Linq.Enumerable.&lt;SelectManyIterator&gt;d__172.MoveNext()
at System.Collections.Generic.List1..ctor(IEnumerable1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable1 source) at FluentValidation.AbstractValidator1.Validate(ValidationContext1 context) in C:\projects\FluentValidation\src\FluentValidation\AbstractValidator.cs:line 114 at FluentValidation.AbstractValidator1.Validate(T instance) in C:\projects\FluentValidation\src\FluentValidation\AbstractValidator.cs:line 95
at NzbDrone.Core.Indexers.Newznab.NewznabSettings.Validate() in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Indexers\Newznab\NewznabSe​ttings.cs:line 92
at NzbDrone.Api.ProviderModuleBase3.Validate(TProviderDefinition definition, Boolean includeWarnings) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ProviderModuleBase.cs:line 199 at NzbDrone.Api.Indexers.IndexerModule.Validate(IndexerDefinition definition, Boolean includeWarnings) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\Indexers\IndexerModule.cs:l​ine 34 at NzbDrone.Api.ProviderModuleBase3.Test(TProviderResource providerResource) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ProviderModuleBase.cs:line 178
at NzbDrone.Api.ProviderModuleBase3.&lt;.ctor&gt;b__1_1(Object x) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Api\ProviderModuleBase.cs:line 28 at CallSite.Target(Closure , CallSite , Func2 , Object )
at Nancy.Routing.Route.<>c__DisplayClass4.<Wrap>b__3(Object parameters, CancellationToken context)


#2

Sorry, Sonarr requires a 800W PSU (kidding of course).

Looks like you’re entering something other than a number in a field that is supposed to contain a number, perhaps the category or anime category?

Next time please post the logs elsewhere and link to them as requested.


#3

DOH!!! I knew that PSU was worthless :stuck_out_tongue:
I’ll install my 1200W :smiley:

I left anime categories blank along with the parameters field. In setup of SickBeard + SABnzbd I left those blank as well and didn’t have any issues. Is this something that should be filled out? What about the categories field, the default has 5030, 5040 I entered tv in that field similar to what I did when I setup SickBeard and SABnzbd.

Sorry about the log post.


#4

@markus101 your comment got me thinking

So I entered the info for the indexer URL, API path, key etc. and left Categories with the default info and it worked. NZBGeek is now connected and saved and I was able to get it working.

Thanks for the help!!!


#5

Leaving Anime categories empty is fine.

Looks like the only case where this would fail in this way is as I mentioned before, with categories containing something that isn’t strictly a number (it’s a comma separated list, so 5030,5040 is fine).

Can you post a screenshot of the settings you’re trying to save (minus the API key)?


#6


This is what my setup looked like where I was getting the error, I was taking this concept from the setup I did with SickBeard and SABnzbd as the guide said to put tv in the Categories field. You gave me an idea so I put the 5030, 5040 in the Categories field instead of tv and it worked.


#7

Yeah. that’s what I meant in my original response; tv isn’t a number. Glad you got it sorted.


closed #8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.