Cannot connect to any Indexers

For indexers it would check every 15 minutes, except when it start failing, which will incrementally block the indexer, up to 24 hours. If it failed in Sonarr consistently and was disabled for 24 hours, but it started working again during that period Sonarr wouldn’t automatically fix it until later.

I mean specifically for Sonarr connecting to things, old certificates used in SAB will trigger Sonarr to disable TLS 1.2, which would cause indexer issues, but not DNS issues like you’re seeing.

Try it in Internet Explorer, any proxies set in IE will be used by Sonarr and IE should show similar issues.

Have you tried different DNS servers? Especially if you’re using the ISP provided ones.

Have you tried without the VPN? If you’re not using public torrent trackers SSL should be enough.

The request was aborted: Could not create SSL/TLS secure channel.

This looks like TLS 1.2 has been disabled.
If you’re using SSL in Sonarr to connect to SAB or other local services with self-signed certificates try connecting insecurely.

I’m a bit hesitant to recommend it since it’s still beta (though very close to replacing v2), but you could try the v3 beta, which if something is causing Sonarr to drop TLS 1.2 it won’t happen in v3 because it’d instead drop the weakly secure connection. If you do decide to try the beta self signed certificates on things Sonarr is connecting to will fail out of the box as Sonarr enforces certificate validation in v3, you can disable it if necessary.

Ok, I am inpatient. I get that! :slight_smile: I may be indeed checking within 24 hours. But last week I was not home, and 4 were marked failed, but when tested, worked immediately. So I need more data and time points here I guess.

Oh! Then NO.

Will need to go get that. Never really use it. But I can confirm no proxies in the browser itself.

Yes to both. I have tried Google, OpenDNS servers, my local IP, and a private DNS server run by a group I know. Same results on all.

It is actually that way for the last month. I turned that off as not really needed. They used to be on seperate machines. Now they are on one.

Oh, I’m game to try v3. Warning: I break software, so I may be posting more bugs or issues. :slight_smile:
Thank you.
-kms

1 Like

So far, V3 on Windows 7 is running like a champ, without disconnecting. All good… fingers crossed.

Update: I spoke too soon. I am seeing the same failure, just taking a bit longer. Indexers show off line, but testing all (nice addition BTW) usually clears them.

Are they failing with the same error?

Yes, but I left it for one cycle, and it recovered. This may have actually been the two indexers gone off line, or a problem with AT&T’s network (would not be the first time.) So far, it is good again. Sorry for the false alarm.

I’m also having similar issue. It is also affecting radarr as well.

This is using Docker on unraid 6.8.3

Disregard, I think it has to do with my proxy I was running through jackett

It looks like I’m having the same issue for the past few weeks at least.

  • The logs show TLS 1.2 disabled and then all indexers fail. http connections to Plex fail.
  • A restart “resets” the issue and once I test the indexers all is fine for potentially, a few hours.

System info:

  • Windows Server 2012 R2
  • 6 GB RAM
  • .NET 4.8
  • HTTPS is on 4 indexers and Pushover (though disabling pushover does nothing)
  • HTTP on Sabnzbd and Plex
  • No DNS errors
  • Tested URLs in IE and Chrome and they work fine.

PS this server hasnt been getting updated in a while so nothing has really changed.

I’ve seen this error twice before, months apart and it was the server time that was wildly out. Fixing that resolved the issue. Time and TZ is spot on now.

Strangely, looking at timings, I seen SSL errors from all 4 indexers through the night (approx 3am - 8am) and 4 files were downloaded successfully between 6am and 8am.

I have tracing enabled but it appears to contain a LOT of sensitive content. Let me know what you need. Thanks for the help and thanks for the awesome app!

Hey again,

Could this be caused by one of the indexers? I can’t see what could else be impacting this. Do you have any thoughts @markus101 ?

Ta

It’s possible, though not super common.

I’m not sure what the best way to narrow down if one or more is causing issues, but enabling each one, one at a time then 2 then 3 might help.