Auto-import issue

Sonarr version (exact version): 3.0.6.1342
Mono version (if Sonarr is not running on Windows):
OS: windows 7
Debug logs: https://pastebin.com/UTn25qp6
https://drive.google.com/file/d/1T0poMalMOjf6fGZHk_-48QeBJ2GKh8Fy/view?usp=sharing

Description of issue:
I seem to be unable to get the importing to work ever after setting up a seedbox to do the downloading portion. I have gone through all the tutorials I can find on setting up the settings for the download client on the remote host and then setting up the remote pathing, when I do the test for the settings everything seems to be good, but when I look at the logs it looks like it is having an issue keeping a connection with rTorrent, I am not sure what to do. Any help is much appreciated, thank you.




<!--- Additional Information: - Information on the log files is here: https://wiki.servarr.com/sonarr/troubleshooting#logging-and-log-files - Make sure debug logging is enabled in settings - Post the log file, not a line or two, or just the error from the Logs table - Post the full log to hastebin/dropbox/google drive or something similar and link it here - Do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document

Your remote path map is incorrect and will never work as input.

Not sure what guides you reviewed but they either did not know what they were doing and were incorrect or you did not fully read them

https://trash-guides.info/Sonarr/Sonarr-remote-path-mapping/

Seeing the “movies” and “series” folders in that location is a huge red flag. Looks like you’re mixing paths for completed downloads and sorted files…

Can you provide any information that could help? I have tried direct paths to series also and that had to effect. I have read that article you posted but maybe I missed the part where I need the remote /completed folder or /completed/series folder to be shared? If that is the case do you have any knowledge on how to go about this on a remote seedbox?

I have also tried doing direct paths to both movies for radarr and series for sonarr and I had no luck with doing that either, unless there is something more I am missing? I have Rtorrent using autotools to move them to those folders using categories.

yes - use the correct remote path.

a remote path map is just a dumb find/replace

the server path /home/twandeez/files/completed is not /home/twandeez/completed which is what you input in the map

this assumes X:\torrent_seedbox is the local mount of /home/twandeez/files/completed

Right, sorry that was an old screenshot, this has been updated to be the path: /home/twandeez/files/completed

With this change there is still no importing occurring.

At a glance it appears that should work, so some logs from the troubleshooting process would be useful now

Okay sure let me provide the latest ones now.

normal log:
https://drive.google.com/file/d/1Cr0bSDV5AMSXuPfsXztINgc2Z4N2NncZ/view?usp=sharing

Trace log:
https://drive.google.com/file/d/10QPB2P6hNWnfO2dn_-J57DEj3xMBjHI9/view?usp=sharing

Debug: log
https://drive.google.com/file/d/1FROpUqqpk4E7e6LTDMIREu_491V6ZZX2/view?usp=sharing

Thank you, and these include from OCT. 01 I believe but changes have been made so the newest records from 04-05 of this month should be most accurate in terms of the errors displayed.

On mobile so maybe I missed it, but I did not see any download import attempts?

We also do not need Info logs nor entire log files.

How can we improve and clarify the 5 step by step instructions on how to provide logs? Note that the troubleshooting sections also explicitly call out this section.
https://wiki.servarr.com/sonarr/troubleshooting#logging-and-log-files

Hello okay sure here is the updated logs cleared out and after a restart:

Trace:
https://drive.google.com/file/d/15TvvHap5ljQKCsoWPKMVOYZayknLRJzb/view?usp=sharing

Debug:
https://drive.google.com/file/d/1lbm-Nl_Ui5VUZTsPxkC24ePptgFcMdDK/view?usp=sharing

still don’t see any import attempts there, but have some info to run with

PS only need trace as it already has debug

/home/(removed)/files/Tosh.0.S08E15.720p.HDTV.x264-MiNDTHEGAP[rarbg].

and if you have x:\torrent_seedbox as the local mount of /home/twandeez/files/completed

then /home/(removed)/files/[anything not 'completed'] will never exist or be seen by Sonarr locally

seems it’s a download client configuration issue on your end?

I don’t quite understand what you mean by as the local mount of /home/twandeez/files/completed.

This is the path on the seedbox itself: /home/twandeez/files/completed
This is the path of my local server which is completely seperate of the seedbox: x:\torrent_seedbox

This is the download client configuration:

When I click test it shows the green checkmark which I am assuming means it is connecting correctly.

Download client in sonarr has nothing to do with the fact that sonarr needs to be able to access the files on your remote seedbox in some shape and form.

So how do you get your files from your seedbox to local?

It seems that’s a remote mount? How is it mounted? What’s the seedbox path on the mount? Does the remote mount on your system match the remote path in the remote path map?
(hint: it does not)

In other words: where and how do you have x:\torrent_seedbox mapped to your remote seedbox

It appears x:\torrent_seedbox is the local equivalent of /home/twandeez/files/completed is it not?

If that’s the case then sonarr will never ever be able to import anything not within your seedboxes completed folder no matter what. It’s simply a poor configuration either in your download client or your mount (and subsequent misalignment with the remote path map)

If you tell sonarr A Is 12345 and your seedbox is saying A is 6789 then why would you think that would work?

I use Syncthing to get the files from the seedbox to my local.

Local:

Remote:

Well the files are synced down to my system so I figured that Sonarr would see the torrent has completed and could scan the local directory for new content and import accordingly. I am not sure how to go about it if that is not that case, or the proper way.

A remote mount setup works better FWIW

See your issue yet?

Again, Nothing not in your completed folder will ever be imported in seen by sonarr

Can you point me in the direction to get a remote mount setup then, I am not sure how to really go about that.

Does anyone know how to setup a remote mount to allow me to get sonarr to do the importing again via this seedbox scenario, or point me in the right direction? Thanks