Another, path does not exist or is not accessible by Sonarr

Outstanding instructions IL2BT! Followed them to the letter…Thank you!

After configuring NZBGet again using the webUI and new creds I’m getting this error:

Portainer volumes look like:

NZBGet Paths look like:

Permissions in the filesystem look like:

Is it possible NZBGet starts before: /volume1/Download/NZBGet/ is mounted?

Also, the NZBGet Container stops after a restart:

Change MainDir to /downloads and DestDir to /downloads/complete or seemingly ${MainDir}/complete would work too (might need to use \ instead of /, but I assume not).

Basically the path you have set for container is what NZBGet will see, and then Docker will translate that to the path you have set for host.

See if that fixes the restart issue, if not then try:
Portainer > Containers > NZBGet > Container details > Restart policies > Always > Update

Great. That solved that problem. Thanks again.

I had a permissions problem on the newly created NZBGet folders. Namely the tmp folder:

Because I set the PUID and PGID to 1000 per the instructions at:https://hub.docker.com/r/linuxserver/nzbget

When I reverted the PUID and PGID to match those of Sonarr (999) as you suggested the problem went away.

I’m currently performing tests. Newly created episode folders have the following permissions:

Thats makes me concerned that Sonarr will have difficulty moving and renaming once the files have completed download.

Seeing as NZBGet and Sonarr both have the same owner (admin), it shhhhhould be fine…
knock on wood
But if there’s any issue, you know where to come :slight_smile:

OK, first episode down.

It actually saved it into:
volume1/Downloads/NZBGet/complete/tv/SERIES/EPISODE

Which I’m quite happy about.

Sonarr on the other hand, threw one of these again:

“Import failed, path does not exist or is not accessible by Sonarr: /downloads/complete/tv/Breeders.S01E03.1080p.AMZN.WEB-DL”

File permissions on:

volume1/Download/NZBGet
volume1/Download/NZBGet/complete
volume1/Download/NZBGet/complete/Breeders/

Are all Read/Write/Execute for Admin / Administrators

However, permissions on:

volume1/Download/NZBGet/complete/tv/Breeders.S01E03.1080p.AMZN.WEB-DL.DD+5.1.H.264-iKA.mkv


For Admin / Administrators.

The weird thing is if I manually set the permissions to be consistent with the containing folders and force NZBGet to reprocess I get the same error in Sonarr’s logs.

I’ve played around with Sonarr > Settings > Media Management > Permissions > OFF / ON with permissions set as 0777 folders and 0666 FIies.

And set the NZBGet > Settings > Unpack > UnrarCmd > ${AppDir}/unrar x -ai

(This should ignore file attributes (permissions) of the downloaded file).

Just haven’t found the magical combination it seems.

Ok, correct me if I’m wrong on any of this:

  1. Sonarr sends the request for the episode or season pack to NZBGet

  2. NZBGet downloads into .../NZBGet/incomplete

  3. once the download finishes it moves the files to .../NZBGet/complete

Apologies for my ignorance here, but are tags then used to move the files again to .../NZBGet/complete/tv, /films, /music, etc.?

  1. if .rar extensions are found it extracts them

When NZBGet extracts, does it extract the file(s) to, for example, .../tv/Breeders.S01E03.1080p.AMZN.WEB-DL, or to .../tv/Breeders?

If the latter, is this something you have specifically set up? If so, you’d need to undo this so it uses the former and let Sonarr do the organising, because NZBGet is feeding Sonarr the location of the .rar files.

Or have I misunderstood, and it’s actually creating copies to both locations? Or have I really misunderstood? :stuck_out_tongue:

Correct

Correct

Actually /NZBGet/complete/tv

Correct (NZBGet logs show - Unrar: All OK. Then Deleting archive files)

In Sonarr > Settings > Download Client > NZBGet > Catagory = tv

I do this because I only use Sonarr for tv shows. Looking at NZBGet’s categories I notice the setting for ‘DestDir’. If left blank it creates the ‘tv’ directory, so that’s working correctly.

It correctly extracts to:
volume1/Download/NZBGet/complete/tv/Breeders.S01E06.1080p.AMZN.WEB-DL

Sonarr is set to create a new series folder into:
volume1/Download/Completed_Shows
Which it does, but the permissions on that folder are:

Not sure if that’s correct or not. But the permissions on:
volume1/Download/NZBGet/complete/tv/Breeders.S01E06.1080p.AMZN.WEB-DL/Breeders.S01E06.1080p.AMZN.WEB-DL.DD+5.1.H.264-iKA.mkv are:

Now, I don’t know if this is a clue or not. But if I attempt to rename the .mkv file I see this:

You’ll note the filename has a ‘+’ in it, which looks to be an invalid character.

Sadly, if I remove the ‘+’ from the file name and ask NZBGet to ‘Post-process Again’ then check Sonarrs logs I still see it fail with:

Import failed, path does not exist or is not accessible by Sonarr: /downloads/complete/tv/Breeders.S01E06.1080p.AMZN.WEB-DL

This is where the files end up:
/volume1/Download/NZBGet/complete/tv/Breeders.S01E06.1080p.AMZN.WEB-DL

But Sonarr’s logs complain of not being able to access:
/downloads/complete/tv/Breeders.S01E06.1080p.AMZN.WEB-DL


Is this right?

Should I change the PUID & PGID to 1000 for both Sonarr and NZBGet?

edit: removed the first part, its been covered

in regards to permissions you set the host path to be owned by the PUID/PGID of the account you are using across all your “media” containers and give it full rights to that folder and all subfolders. if you do that then you shouldnt have any access issues at all, and you shouldnt need sonarr to change permissions.

if youre using different PUIDs for each container then make sure all of them are in the PGID group so they have full control

you may want to use this command to connect to the container and check the volume mappings exist, the path is there, and that you have access;
docker exec -it YOUR_CONTAINER_NAME_GOES_HERE bash

Thanks rhom
The PUID and PGID for both the Sonarr and NZBGet containers inside Docker are set to: 999

The Sonarr PUID and PGID was set automatically during the upgrade from non-docker to dockerized version of the app installed from Asustor’s App Central.

With IL2BT’s help I set the NZBGet PUID and PGID to match Sonarr’s.

Access control for both containers and volume1/Download is set to administrators.

is 999 an actual user on your nas?

ie typically you create a user id on the host, add it to a group, then get the IDs for both and set them for the container

the linuxserver containers typically run as user abc and group abc, and the bootup process resets their IDs to the PUID and PGID you set on the container, this effectively makes them the same IDs inside and outside which is how docker security works (the container IDs line up with the host IDs making them the same users and groups from a host security/access perspective)

from the looks of one of your previous posts the actual IDs are 1000/1000 so if 999 isnt a valid user on your host, and 1000 is, then you need to change the container to use 1000, then delete and re-create the container (not the container setup/config) so it picks up that change

note - the ownership there might be for docker, not the underlying volumes. you need to note down all the host paths mapped into each container and ensure that (for example) user 1000 is the owner (so has full control), and group 1000 also has full control (including to subfolders), so for asustor youd use the adm file explorer, or SSH in and use *nix commands

Search as I might, I’m unable to find reference to PUID or PGID in the Asustor NAS ADM.

I tried setting both Sonarr, and NZBGet to PUID 1000 and PGiD 1000 from Portainer and tested.

Whilst both UI’s were navigable they would not function. Sonarr for example wouldn’t clear its logs or search series.

Reverting back to 999 for both seems to restore function.

Is there a method in my configuration to confirm what access rights Sonarr has to:
/downloads/complete/tv/Breeders.S01E05.1080p.AMZN.WEB-DL

I have both Sonarr and NZBget running in Docker and using Portainer as a UI in a Asustor NAS

ADM > Access Control > Local Users > admin > Edit > UID - 999
" > " > Local Groups > administrators > GID - 999
Same for you?

/volume1/Download/NZBGet is correct, yes.

Should have checked last night, but here are my permissions, no issues:

/Media

/Media/Complete

/Media/Complete/[folder]

/Media/Complete/[folder]/[files.ext]

/Media/TV

/Media/TV/[Folder]

/Media/TV/[Folder]/[Files.ext]

Yup, same as you

The permissions look the same as yours.

You can see that the Sonarr error message lists the correct path. So it’s looking in the right place.

Sonarr’s volumes look like:
Screen Shot 2020-04-27 at 8.36.30 PM

NZBGet’s volumes look like:

Do you think I need to remove ‘NZBGet’ from the end of /volume1/Download/NZBGet. Then amend the MainDir path in NZBGet to: /downloads/NZBGet

Yea, give it a shot

yes, they must be identical or it wont work.

and yes, you also need to reconfigure nzbget so the maindir is set to /downloads/nzbget and the destdir is set to /downloads/nzbget/complete

SUCCESS!

Thank you @ilike2burnthing @rhom @Thirrian for sticking with me!

TL:DR
It seems a dockerized Sonarr didn’t have permissions to directories that a non-dockerized NZBGet was using.

The solution for my Asustor NAS was to:

  1. Add NZBGet to Docker via Portainer.
  2. Use the same PUID and PGID of 999 for both Sonarr and NZBGet
  3. Use the same directories for both Sonarr and NZBGet in Docker HOST: /volume1/Download PATH: /downloads
  4. Set NZBGet’s MainDir path: /downloads/NZBGet/
  5. Set NZBGet’s DestDir path: /downloads/NZBGet/complete

Unsure if these settings made an impact or not:

  1. NZBGet > Settings > Unpack > UnrarCmd = ${AppDir}/unrar x -ai;

Winning combination


NZBGet Docker Volume

Sonarr Docker Volume

NZBGet Path

Thanks again Gents :grinning:

1 Like

Yay! Happy downloading! :wink:

Thanks again IL2BT

I’ve taken your Docker instructions and used them to install Radarr with great success.

:+1:t3:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.