All indexers failing

Sonarr version (exact version): Sonarr Ver. 2.0.0.5322
Mono version (if Sonarr is not running on Windows): 5.20.1.19
OS: Docker on Synology DSM 6.2.2-24922
Debug logs: https://pastebin.com/0GxJbr0p
Description of issue:

It seems like every so often (days to weeks), sonarr will no longer connect to the indexers and I’ll get the “All indexers are unavailable due to failures” error. I have the full radarr, sonarr, transmission, plex, jackett combo, but during this time that sonarr gives me errors, radarr will still be able to connect to the exact same indexers. I can fully resolve this by restarting the container, but anything that was released while the indexes failed has to be searched again. I’ve attempted to get a new image a few days ago, but that did not prevent it from happening again.

Here’s a portion of my trace log file when it happens, although I can’t notice anything important: https://pastebin.com/0GxJbr0p

For referece, I’m running sonarr in docker (linuxserver image) on a Synology DS918+

Known issue with mono, earlier mono versions don’t seem to have that issue (5.10 or 5.12).

I have the same version of mono in both Radarr and Sonarr, but the issue only exists within Sonarr (I have never had the indexer error in Radarr).

Radarr: Mono Version: 5.20.1.19 (tarball Thu Apr 11 09:09:21 UTC 2019)
Sonarr: Mono Version: 5.20.1.19

All indexers are unavailable due to failures
All search-capable indexers are temporarily unavailable due to recent indexer errors
All rss-capable indexers are temporarily unavailable due to recent indexer errors

DNS Name Resolution Failure:
Sonarr Version 2.0.0.5322
have to keep resetting or reboot the pc to get it working or it will not function. It’s only been doing this from this version last update.

RssSyncService Starting RSS Sync 16:43
RssSyncService RSS Sync Completed. Reports found: 0, Reports grabbed: 0 16:33
DownloadDecisionMaker No results found 16:33
Newznab usenet-crawler https://www.usenet-crawler.com/api?t=tvsearch&cat=5030,5040&extended=1&apikey=(removed)&offset=0&limit=100 DNS Name Resolution Failure: ‘www.usenet-crawler.com 16:33
Newznab nzbplanet https://api.nzbplanet.net/api?t=tvsearch&cat=5030,5040&extended=1&apikey=(removed)&offset=0&limit=100 DNS Name Resolution Failure: ‘api.nzbplanet.net 16:33
Newznab NZBcat https://nzb.cat/api?t=tvsearch&cat=5030,5040&extended=1&apikey=(removed)&offset=0&limit=100 DNS Name Resolution Failure: ‘nzb.cat’

will there be a fix or might have to down grade to solve.
many thanks

That’s a problem with DNS on the system Sonarr is running on, similar result, but a different cause.

been fine for months until now,all other computers not an isue, can reset nic and still not working only if i reboot sonarr or re boot pc it will run again until it decides not to,even donebackup reinstal of image of an early version works fine until it up dates again to this version.

Nothing has recently changed with that version, it’s 3 months old.

an early version works fine until it up dates again to this version.

Which version is that?